# CVE-2026-54428: Apache HttpComponents Core: HPackDecoder Unlimited Header List Size Before SETTINGS ACK

> Remote attackers can cause denial of service via memory exhaustion in Apache HttpComponents Core by sending oversized HPACK headers before SETTINGS ACK.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2026
- **Updated:** 1 Jul 2026
- **Also known as:** CLEANSTART-2026-FB65905, CLEANSTART-2026-GO38541, CLEANSTART-2026-MM56894, CLEANSTART-2026-SC69074, CLEANSTART-2026-XZ10656, CLSA-2026-1789375936, DEBIAN-CVE-2026-54428, ECHO-e357-b23c-1252, GHSA-v3jc-474w-2wm6, MINI-2xqp-2p4c-j3mm, MINI-45w5-7vp8-cfpc, MINI-4f6f-43rp-59wq, MINI-54m9-px5v-56rj, MINI-575g-ff96-q4fg, MINI-6684-f5ch-3936, MINI-67cc-m87r-h763, MINI-79rj-vmq9-6hqf, MINI-c983-gpxh-cv47, MINI-cqmr-r23v-c52q, MINI-f489-rj7v-hwrr, MINI-f4hx-5659-w9w9, MINI-fmm6-f66f-qj67, MINI-g25r-7x83-4qq3, MINI-g78g-3p3q-65fm, MINI-jh9p-7jvw-v27v, MINI-jhh8-9g49-xhq5, MINI-jw7c-3p2h-j746, MINI-m53p-r8m9-3x2q, MINI-mmc2-hgrw-29gf, MINI-p66p-gq99-24cg, MINI-p7jj-37fc-2373, MINI-pchv-8xf6-g48h, MINI-pjj6-6xqx-vfq3, MINI-qfqp-xjf4-284q, MINI-qgfg-7r25-q9vx, MINI-qhcr-4jjc-4gr3, MINI-qw3q-3rhg-4jgm, MINI-r6m3-r7qm-32ph, MINI-vfqj-m944-hgxr, MINI-w4xr-957f-prw5, MINI-wp4c-8w2p-mqv2, MINI-wr6r-8jvh-43w4, MINI-x5j7-qmh2-2wx8, ROOT-APP-MAVEN-CVE-2026-54428, UBUNTU-CVE-2026-54428

## What is CVE-2026-54428?

CVE-2026-54428 is a high-severity denial of service vulnerability in Apache HttpComponents Core, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Allocation of resources without limits or throttling in the HTTP/2 HPACK decoder in Apache HttpComponents Core (5.4.2 and earlier, 5.5-beta1 and earlier) allows an remote attacker to cause a denial of service through memory exhaustion by sending oversized compressed header blocks before the HTTP/2 SETTINGS acknowledgement causes the configured header list size limit to be applied.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-54428?

4 open source packages ship an affected version, including org.apache.httpcomponents.core5:httpcore5-h2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.httpcomponents.core5:httpcore5-h2` | Maven | All versions | 5.4.3 |
| `org.apache.httpcomponents.core5:httpcore5-h2` | Maven | All versions | 5.4.3 |
| `org.apache.httpcomponents.core5:httpcore5-h2` | Maven | From 5.5-alpha1 | 5.5-beta2 |
| `org.apache.httpcomponents.core5:httpcore5-h2` | Maven | From 5.5-alpha1 | 5.5-beta2 |

Products: Apache Httpcomponents Core.

## How do I fix CVE-2026-54428?

Upgrade org.apache.httpcomponents.core5:httpcore5-h2 to a fixed version for your release line: 5.4.3 or 5.5-beta2.

## Is CVE-2026-54428 being exploited?

There is no known exploitation of CVE-2026-54428 in the wild and no public exploit code.

## Other vulnerabilities in Apache HttpComponents Core

- [CVE-2026-54399](https://insights.sbomify.com/CVE-2026-54399/): Apache HttpComponents Core: Unbounded HTTP Header/Line Length in Default Configuration (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54428 and fix it if it is affected.

What it is: CVE-2026-54428 is a high-severity denial of service vulnerability in Apache HttpComponents Core, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54428 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.httpcomponents.core5:httpcore5-h2 (Maven): affected all versions; fixed in 5.4.3
- org.apache.httpcomponents.core5:httpcore5-h2 (Maven): affected all versions; fixed in 5.4.3
- org.apache.httpcomponents.core5:httpcore5-h2 (Maven): affected from 5.5-alpha1; fixed in 5.5-beta2
- org.apache.httpcomponents.core5:httpcore5-h2 (Maven): affected from 5.5-alpha1; fixed in 5.5-beta2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54428/ (Markdown: https://insights.sbomify.com/CVE-2026-54428/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54428
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54428
- OSV: https://osv.dev/vulnerability/CVE-2026-54428

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54428/
Summaries are generated and may contain mistakes; the official description above is the record.
