CVE-2026-54450 ToolHive: SSRF guard misses IPv6 NAT64 ranges (64:ff9b::/96, 64:ff9b:1::/48), allowing metadata/internal access behind a NAT64 gateway

Low 2.9 Published Updated

Attacker can bypass SSRF protections via IPv6 NAT64 addresses to probe internal network reachability on ToolHive deployments behind NAT64 gateways.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-54450?

CVE-2026-54450 is a low-severity server-side request forgery vulnerability in stacklok toolhive, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

ToolHive is a utility designed to simplify the deployment and management of Model Context Protocol (MCP) servers. Prior to 0.29.1, networking.IsPrivateIP in pkg/networking/utilities.go omits the IPv6 NAT64 prefixes 64:ff9b::/96 and 64:ff9b:1::/48, so NAT64 addresses embedding private, loopback, or link-local IPv4 targets are classified as public and allowed. The most direct attacker-controlled path begins when an external OAuth client supplies a client_id URL that CIMDStorageDecorator.GetClient routes through FetchClientMetadataDocument in pkg/oauthproto/cimd/fetch.go; protectedDialerControl in pkg/networking/http_client.go and validateHost in pkg/skills/gitresolver/reference.go share the defective classification but use operator-controlled or user-controlled destinations. On a ToolHive host behind a NAT64/DNS64 gateway, the gateway translates an allowed address such as 64:ff9b:1::a9fe:a9fe to 169.254.169.254, permitting blind probing of internal TCP or TLS reachability. The attacker-controlled CIMD path requires HTTPS, verifies certificates, and does not reflect response bodies, so the established impact is an internal reachability oracle rather than metadata credential exfiltration; the webhook client is not affected because it does not use this IP guard. This issue is fixed in version 0.29.1.

Weakness: CWE-918

Which versions are affected by CVE-2026-54450?

3 open source packages ship an affected version, including github.com/stacklok/toolhive.

PackageAffectedFixed in
github.com/stacklok/toolhive GoAll versions0.29.1
github.com/stacklok/toolhive GoAll versions0.29.1
github.com/stacklok/toolhive GoAll versions0.29.1

How do I fix CVE-2026-54450?

Upgrade github.com/stacklok/toolhive to 0.29.1 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2026-54450 being exploited?

There is no known exploitation of CVE-2026-54450 in the wild and no public exploit code.

Sources

Also known as GHSA-pph6-vfjv-vpjw, GO-2026-5996.

Is CVE-2026-54450 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free