# CVE-2026-54451: Elixir protobuf: Unbounded recursion depth in embedded-message decoding

> Attackers can cause denial of service in Elixir applications by sending deeply nested protobuf messages that exhaust CPU and memory resources.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** GHSA-rv48-qqj5-crxg, UBUNTU-CVE-2026-54451

## What is CVE-2026-54451?

CVE-2026-54451 is a high-severity denial of service vulnerability in elixir-protobuf protobuf, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Elixir protobuf is a pure Elixir implementation of Google Protobuf. From 0.8.0 until 0.16.1, services that decode attacker-controlled protobuf bytes with Protobuf.Decoder can be taken offline when the schema contains a self-referential or cyclic message type. In lib/protobuf/decoder.ex, Protobuf.Decoder.value_for_field/3 handles an embedded?: true field by recursively entering the decode / build_message / handle_value / value_for_field call chain without enforcing a nesting-depth limit. Deeply nested embedded fields retain non-tail recursive frames, allowing a comparatively small request to consume substantial CPU and memory, pin a BEAM scheduler, and exhaust the node. This issue is fixed in version 0.16.1.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-54451?

2 open source packages ship an affected version, including protobuf.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `protobuf` | Hex | From 0.8.0 | 0.16.1 |
| `protobuf` | Hex | From 0.8.0 | 0.16.1 |

## How do I fix CVE-2026-54451?

Upgrade protobuf to 0.16.1 or later.

## Is CVE-2026-54451 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54451 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54451 and fix it if it is affected.

What it is: CVE-2026-54451 is a high-severity denial of service vulnerability in elixir-protobuf protobuf, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54451 exists.

Affected packages and fixed versions:
- protobuf (Hex): affected from 0.8.0; fixed in 0.16.1
- protobuf (Hex): affected from 0.8.0; fixed in 0.16.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54451/ (Markdown: https://insights.sbomify.com/CVE-2026-54451/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54451
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54451
- OSV: https://osv.dev/vulnerability/CVE-2026-54451

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54451/
Summaries are generated and may contain mistakes; the official description above is the record.
