# CVE-2026-54454: OpenCATS: Authenticated RCE in the Import module

> Authenticated users can upload PHP files to a web-accessible directory, leading to remote code execution if PHP execution is enabled in that directory.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-v9gx-5qhj-jf7c

## What is CVE-2026-54454?

CVE-2026-54454 is a critical vulnerability in OpenCATS, published on 13 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

OpenCATS is an open-source applicant tracking system and recruitment CRM for staffing agencies and hiring teams. Prior to 0.10.0, the OpenCATS Import module in modules/import/ImportUI.php can preserve an uploaded file's original name for one import data type and place the file in the web-accessible temporary directory. An authenticated user with Import privileges can select the affected import path and upload a PHP file that remains under an attacker-controlled executable filename, and an import error can leave the file on disk. If the temporary directory is served with PHP execution enabled, requesting the staged file can execute arbitrary PHP code with the web server process privileges, exposing or modifying recruiting data and the host system. This issue is fixed in version 0.10.0.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-54454?


## How do I fix CVE-2026-54454?

No fix has been published for CVE-2026-54454 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54454 being exploited?

There is no known exploitation of CVE-2026-54454 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54454 and fix it if it is affected.

What it is: CVE-2026-54454 is a critical vulnerability in OpenCATS, published on 13 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54454 in the wild and no public exploit code.

Affected product: OpenCATS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54454/ (Markdown: https://insights.sbomify.com/CVE-2026-54454/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54454
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54454
- OSV: https://osv.dev/vulnerability/CVE-2026-54454

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54454/
Summaries are generated and may contain mistakes; the official description above is the record.
