# CVE-2026-54465: websocket-driver: Memory exhaustion in HTTP header parser

> A remote attacker can cause memory exhaustion and denial of service in applications using the websocket-driver library by sending excessive HTTP headers.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** CLSA-2026-1790944051, DEBIAN-CVE-2026-54465, GHSA-8j3g-f24p-4mpw, MINI-fw6f-crwq-545w, MINI-jrjr-cc7r-pvxc, UBUNTU-CVE-2026-54465

## What is CVE-2026-54465?

CVE-2026-54465 is a medium-severity denial of service vulnerability in faye websocket-driver-ruby, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

websocket-driver is a WebSocket protocol handler with pluggable I/O. Prior to 0.8.1, when websocket-driver is used to implement a WebSocket server on top of a TCP server using WebSocket::Driver.server() or to complement a WebSocket client, a peer can make a single connection consume an unbounded amount of memory by sending an HTTP request or response with a never-ending list of headers. This can lead to the receiving process running out of memory. This issue is fixed in version 0.8.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-54465?

2 open source packages ship an affected version, including websocket-driver. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `websocket-driver` | RubyGems | All versions | 0.8.1 |
| `websocket-driver` | RubyGems | All versions | 0.8.1 |

Products: Faye Websocket-Driver.

## How do I fix CVE-2026-54465?

Upgrade websocket-driver to 0.8.1 or later.

## Is CVE-2026-54465 being exploited?

There is no known exploitation of CVE-2026-54465 in the wild and no public exploit code.

## Other vulnerabilities in faye websocket-driver-ruby

- [CVE-2026-54466](https://insights.sbomify.com/CVE-2026-54466/): websocket-driver: Message corruption via abuse of protocol length headers (critical 9.2)
- [CVE-2026-54463](https://insights.sbomify.com/CVE-2026-54463/): websocket-driver: Memory exhaustion via abuse of protocol length headers (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54465 and fix it if it is affected.

What it is: CVE-2026-54465 is a medium-severity denial of service vulnerability in faye websocket-driver-ruby, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54465 in the wild and no public exploit code.

Affected packages and fixed versions:
- websocket-driver (RubyGems): affected all versions; fixed in 0.8.1
- websocket-driver (RubyGems): affected all versions; fixed in 0.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54465/ (Markdown: https://insights.sbomify.com/CVE-2026-54465/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54465
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54465
- OSV: https://osv.dev/vulnerability/CVE-2026-54465

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54465/
Summaries are generated and may contain mistakes; the official description above is the record.
