{"answers":{"affected":"3 open source packages ship an affected version, including code.gitea.io/gitea and gitea.dev.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54481 exists.","fix":"Upgrade code.gitea.io/gitea to 1.27.0 or later.","what":"CVE-2026-54481 is a high-severity vulnerability in Gitea Open Source Git Server, published on 13 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-54481 and fix it if it is affected.\n\nWhat it is: CVE-2026-54481 is a high-severity vulnerability in Gitea Open Source Git Server, published on 13 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54481 exists.\n\nAffected packages and fixed versions:\n- code.gitea.io/gitea (Go): affected all versions; fixed in 1.27.0\n- code.gitea.io/gitea (Go): affected all versions; fixed in 1.27.0\n- gitea.dev (Go): affected all versions; fixed in 1.27.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54481/ (Markdown: https://insights.sbomify.com/CVE-2026-54481/index.md)","id":"CVE-2026-54481","markdown":"https://insights.sbomify.com/CVE-2026-54481/index.md","name":"CVE-2026-54481","record":{"aliases":["GHSA-94v3-77j7-vm48","GO-2026-6048","MINI-5wj9-jxwp-fpf7","MINI-xpf2-87vg-wh5q"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_read","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Git server","requires_auth":"none","summary":"The internal API client disables TLS certificate verification, allowing attackers to intercept or manipulate traffic via man-in-the-middle attacks.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Gitea","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Internal API HTTP client hardcodes InsecureSkipVerify:true with no config override (CWE-295)","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Internal API HTTP client hardcodes InsecureSkipVerify:true with no config override (CWE-295)","id":"CVE-2026-54481","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Command injection in PowerProtect Data Domain","id":"CVE-2026-54483"},"packages":[{"ecosystem":"Go","fixed":["1.27.0"],"introduced":["0"],"last_affected":[],"package":"code.gitea.io/gitea","purl":null,"source":"GHSA-94v3-77j7-vm48"},{"ecosystem":"Go","fixed":["1.27.0"],"introduced":["0"],"last_affected":[],"package":"code.gitea.io/gitea","purl":"pkg:golang/code.gitea.io/gitea","source":"GHSA-94v3-77j7-vm48"},{"ecosystem":"Go","fixed":["1.27.0"],"introduced":["0"],"last_affected":[],"package":"gitea.dev","purl":"pkg:golang/gitea.dev","source":"GO-2026-6048"}],"prev":{"headline":"EVoke Systems EVoke CSMS Insufficient Session Expiration","id":"CVE-2026-54479"},"products":["Gitea Open Source Git Server"],"published":"2026-08-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-14","vendors":["Gitea"]},"summary":"The internal API client disables TLS certificate verification, allowing attackers to intercept or manipulate traffic via man-in-the-middle attacks.","url":"https://insights.sbomify.com/CVE-2026-54481/"}