# CVE-2026-54481: Internal API HTTP client hardcodes InsecureSkipVerify:true with no config override (CWE-295)

> The internal API client disables TLS certificate verification, allowing attackers to intercept or manipulate traffic via man-in-the-middle attacks.

- **Severity:** High 7.5 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-94v3-77j7-vm48, GO-2026-6048, MINI-5wj9-jxwp-fpf7, MINI-xpf2-87vg-wh5q

## What is CVE-2026-54481?

CVE-2026-54481 is a high-severity vulnerability in Gitea Open Source Git Server, published on 13 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Internal API HTTP client hardcodes InsecureSkipVerify:true with no config override (CWE-295)

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-54481?

3 open source packages ship an affected version, including code.gitea.io/gitea and gitea.dev.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.gitea.io/gitea` | Go | All versions | 1.27.0 |
| `code.gitea.io/gitea` | Go | All versions | 1.27.0 |
| `gitea.dev` | Go | All versions | 1.27.0 |

## How do I fix CVE-2026-54481?

Upgrade code.gitea.io/gitea to 1.27.0 or later.

## Is CVE-2026-54481 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54481 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54481 and fix it if it is affected.

What it is: CVE-2026-54481 is a high-severity vulnerability in Gitea Open Source Git Server, published on 13 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54481 exists.

Affected packages and fixed versions:
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.27.0
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.27.0
- gitea.dev (Go): affected all versions; fixed in 1.27.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54481/ (Markdown: https://insights.sbomify.com/CVE-2026-54481/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54481
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54481
- OSV: https://osv.dev/vulnerability/CVE-2026-54481

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54481/
Summaries are generated and may contain mistakes; the official description above is the record.
