# CVE-2026-54492: Koel: Authenticated Blind SSRF via Subsonic Podcast Channel Creation

> Authenticated attackers can trigger server-side requests to internal networks via the Subsonic podcast creation route, bypassing URL validation.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 20 Aug 2026
- **Also known as:** GHSA-w79m-f3jx-779v

## What is CVE-2026-54492?

CVE-2026-54492 is a medium-severity server-side request forgery vulnerability in koel, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Koel is a free, open-source music streaming solution. Prior to 9.7.0, the Subsonic-compatible createPodcastChannel.view route accepts an authenticated user's private URL because app/Http/Requests/Subsonic/CreatePodcastChannelRequest.php does not apply the SafeUrl validation used by the regular podcast API. app/Http/Controllers/Subsonic/CreatePodcastChannelController.php passes the URL to app/Services/Podcast/PodcastService.php, where PodcastService::addPodcast() and createParser() invoke Poddle::fromUrl() during channel creation, causing immediate server-side requests to loopback, Docker bridge, or RFC1918 HTTP destinations. The confirmed impact is blind internal request execution because generic response-body exfiltration was not demonstrated through this route. This issue is fixed in version 9.7.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-54492?

2 open source packages ship an affected version, including phanan/koel.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phanan/koel` | Packagist | All versions | 9.7.0 |
| `phanan/koel` | Packagist | All versions | 9.7.0 |

## How do I fix CVE-2026-54492?

Upgrade phanan/koel to 9.7.0 or later.

## Is CVE-2026-54492 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54492 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54492 and fix it if it is affected.

What it is: CVE-2026-54492 is a medium-severity server-side request forgery vulnerability in koel, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54492 exists.

Affected packages and fixed versions:
- phanan/koel (Packagist): affected all versions; fixed in 9.7.0
- phanan/koel (Packagist): affected all versions; fixed in 9.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54492/ (Markdown: https://insights.sbomify.com/CVE-2026-54492/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54492
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54492
- OSV: https://osv.dev/vulnerability/CVE-2026-54492

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54492/
Summaries are generated and may contain mistakes; the official description above is the record.
