CVE-2026-54511 @logtape/syslog: syslog log injection via unescaped control characters and unvalidated SD-NAME keys
Attackers can forge syslog records by injecting control characters or invalid keys when structured data logging is enabled, compromising SIEM integrity.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-54511?
CVE-2026-54511 is a high-severity vulnerability in dahlia logtape, published on 26 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
LogTape is an unobtrusive logging library. Prior to 1.3.11, 2.0.14, and 2.1.5, the @logtape/syslog package's escapeStructuredDataValue() function in packages/syslog/src/syslog.ts does not neutralize C0 control characters from U+0000 through U+001F in structured data values, and formatStructuredData() inserts property keys without validating the RFC 5424 SD-NAME grammar. When includeStructuredData is true, an attacker-controlled newline can terminate an RFC 6587 non-transparent TCP syslog frame and make following bytes appear as a forged RFC 5424 record, while a key containing a closing bracket or other forbidden character can terminate or corrupt the structured-data element. Applications that forward attacker-controlled property values or keys can therefore allow forged records with arbitrary hosts, applications, process identifiers, facilities, or severity levels, undermining downstream collector and SIEM integrity. This issue is fixed in versions 1.3.11, 2.0.14, and 2.1.5.
Which versions are affected by CVE-2026-54511?
6 open source packages ship an affected version, including @logtape/syslog.
| Package | Affected | Fixed in |
|---|---|---|
@logtape/syslog npm | All versions | 1.3.11 |
@logtape/syslog npm | All versions | 1.3.11 |
@logtape/syslog npm | From 2.0.0 | 2.0.14 |
@logtape/syslog npm | From 2.0.0 | 2.0.14 |
@logtape/syslog npm | From 2.1.0 | 2.1.5 |
@logtape/syslog npm | From 2.1.0 | 2.1.5 |
How do I fix CVE-2026-54511?
Upgrade @logtape/syslog to a fixed version for your release line: 1.3.11, 2.0.14 or 2.1.5.
Is CVE-2026-54511 being exploited?
There is no known exploitation of CVE-2026-54511 in the wild and no public exploit code.
Sources
Also known as GHSA-8h6h-x5pq-56fq.