# CVE-2026-54528: jupyterlab-git excluded_paths Case-Sensitivity Bypass Allows Reading Excluded Directories

> An authenticated user can bypass excluded path restrictions in JupyterLab Git by varying URL casing on case-insensitive filesystems, allowing unauthorized directory access.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-436q-jwfr-rm2h, PYSEC-2026-2539

## What is CVE-2026-54528?

CVE-2026-54528 is a high-severity vulnerability in jupyterlab-git, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

JupyterLab Git is a Git extension for JupyterLab. Prior to 0.54.0, jupyterlab-git uses fnmatch.fnmatchcase() in GitHandler.prepare() in jupyterlab_git/handlers.py to enforce excluded_paths, allowing an authenticated user on a case-insensitive filesystem to vary URL path casing and read excluded directories. This issue is fixed in version 0.54.0.

Weakness: CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2026-54528?

3 open source packages ship an affected version, including jupyterlab-git. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyterlab-git` | PyPI | All versions | 0.54.0 |
| `jupyterlab-git` | PyPI | All versions | 0.54.0 |
| `jupyterlab-git` | PyPI | All versions | 0.54.0 |

Products: Jupyter Jupyterlab-Git.

## How do I fix CVE-2026-54528?

Upgrade jupyterlab-git to 0.54.0 or later.

## Is CVE-2026-54528 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54528 exists.

## Other vulnerabilities in jupyterlab-git

- [CVE-2026-54527](https://insights.sbomify.com/CVE-2026-54527/): JupyterLab Git: Stored XSS leading to RCE (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54528 and fix it if it is affected.

What it is: CVE-2026-54528 is a high-severity vulnerability in jupyterlab-git, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54528 exists.

Affected packages and fixed versions:
- jupyterlab-git (PyPI): affected all versions; fixed in 0.54.0
- jupyterlab-git (PyPI): affected all versions; fixed in 0.54.0
- jupyterlab-git (PyPI): affected all versions; fixed in 0.54.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54528/ (Markdown: https://insights.sbomify.com/CVE-2026-54528/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54528
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54528
- OSV: https://osv.dev/vulnerability/CVE-2026-54528

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54528/
Summaries are generated and may contain mistakes; the official description above is the record.
