# CVE-2026-54533: vantage6 node has an Improper Access Control issue

> Malicious algorithms can access other algorithms' input and output files due to improper access control in vantage6 nodes.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 18 Jun 2026
- **Also known as:** GHSA-x9f6-9rvm-mmrg, PYSEC-2026-3401

## What is CVE-2026-54533?

CVE-2026-54533 is a medium-severity missing authorization vulnerability in vantage6, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vantage6 is an open-source infrastructure for privacy preserving analysis. Prior to version 5.0.0, malicious algorithms can potentially access other algorithms input and output files. Version 5.0.0 fixes the issue. As a workaround, verify and restrict the algorithm containers that are allowed to run on the node.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-54533?

3 open source packages ship an affected version, including vantage6.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vantage6` | PyPI | All versions | 5.0.0 |
| `vantage6` | PyPI | All versions | 5.0.0 |
| `vantage6` | PyPI | All versions | 5.0.0 |

## How do I fix CVE-2026-54533?

Upgrade vantage6 to 5.0.0 or later.

## Is CVE-2026-54533 being exploited?

There is no known exploitation of CVE-2026-54533 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54533 and fix it if it is affected.

What it is: CVE-2026-54533 is a medium-severity missing authorization vulnerability in vantage6, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54533 in the wild and no public exploit code.

Affected packages and fixed versions:
- vantage6 (PyPI): affected all versions; fixed in 5.0.0
- vantage6 (PyPI): affected all versions; fixed in 5.0.0
- vantage6 (PyPI): affected all versions; fixed in 5.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54533/ (Markdown: https://insights.sbomify.com/CVE-2026-54533/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54533
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54533
- OSV: https://osv.dev/vulnerability/CVE-2026-54533

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54533/
Summaries are generated and may contain mistakes; the official description above is the record.
