# CVE-2026-54540: Authenticated terminal command whitelist bypass in Pheditor

> Authenticated users can bypass terminal command whitelists via shell substitution to execute arbitrary commands as the web server user.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2026
- **Updated:** 27 Jul 2026
- **Also known as:** GHSA-9643-6xjp-vx57

## What is CVE-2026-54540?

CVE-2026-54540 is a high-severity command injection vulnerability in pheditor, published on 27 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pheditor is a single-file editor and file manager written in PHP. Prior to version 2.0.5, there is an authenticated terminal command whitelist bypass. The terminal feature checks whether the submitted command starts with one of the configured TERMINAL_COMMANDS values, then passes the full command string to shell_exec(). Shell command substitution such as $() is not blocked, so an authenticated user with the terminal permission can bypass a restricted command allowlist and execute arbitrary shell commands as the web server user. This issue has been patched in version 2.0.5.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-54540?

2 open source packages ship an affected version, including pheditor/pheditor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pheditor/pheditor` | Packagist | All versions | 2.0.5 |
| `pheditor/pheditor` | Packagist | All versions | 2.0.5 |

## How do I fix CVE-2026-54540?

Upgrade pheditor/pheditor to 2.0.5 or later.

## Is CVE-2026-54540 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54540 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54540 and fix it if it is affected.

What it is: CVE-2026-54540 is a high-severity command injection vulnerability in pheditor, published on 27 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54540 exists.

Affected packages and fixed versions:
- pheditor/pheditor (Packagist): affected all versions; fixed in 2.0.5
- pheditor/pheditor (Packagist): affected all versions; fixed in 2.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54540/ (Markdown: https://insights.sbomify.com/CVE-2026-54540/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54540
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54540
- OSV: https://osv.dev/vulnerability/CVE-2026-54540

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54540/
Summaries are generated and may contain mistakes; the official description above is the record.
