# CVE-2026-54543: Froxlor DomainZones.add allows DNS zone-file RR injection via record/type fields

> Authenticated users can inject malicious DNS records into zone files via the DomainZones.add API, allowing unauthorized DNS data modification and potential service disruption.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-5rw4-4665-cvwf

## What is CVE-2026-54543?

CVE-2026-54543 is a medium-severity vulnerability in froxlor, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Froxlor is open source server administration software. Prior to 2.3.8, the DomainZones.add API command in lib/Froxlor/Api/Commands/DomainZones.php accepts user-controlled record and type values without rejecting line delimiters, tab characters, semicolons, or unsupported DNS record types before lib/Froxlor/Dns/DnsEntry.php serializes the values into a BIND zone file. An authenticated customer with DNS-zone permissions can place a crafted value in the record field, or use the related type-field variant, to create additional resource-record lines that bypass Froxlor's field-level validation. BIND accepts the injected records, allowing modification of DNS data and possible DNS availability impact within a zone the caller is authorized to manage. This issue is fixed in version 2.3.8.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-54543?

2 open source packages ship an affected version, including froxlor/froxlor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | All versions | 2.3.8 |
| `froxlor/froxlor` | Packagist | All versions | 2.3.8 |

## How do I fix CVE-2026-54543?

Upgrade froxlor/froxlor to 2.3.8 or later.

## Is CVE-2026-54543 being exploited?

There is no known exploitation of CVE-2026-54543 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54543 and fix it if it is affected.

What it is: CVE-2026-54543 is a medium-severity vulnerability in froxlor, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54543 in the wild and no public exploit code.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.8
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54543/ (Markdown: https://insights.sbomify.com/CVE-2026-54543/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54543
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54543
- OSV: https://osv.dev/vulnerability/CVE-2026-54543

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54543/
Summaries are generated and may contain mistakes; the official description above is the record.
