# CVE-2026-54545: @wakaru/cli arbitrary file write during bundle unpack

> Attackers can write files outside the output directory via crafted filenames in malicious bundles, potentially achieving code execution when users unpack them.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** GHSA-7wpj-vvmv-pgm8

## What is CVE-2026-54545?

CVE-2026-54545 is a high-severity path traversal vulnerability in pionxzh wakaru, published on 28 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

wakaru is a JavaScript decompiler and unminifier toolkit. From 1.0.0 until 1.4.0, @wakaru/cli sanitizes bundle-controlled module filenames only once before writing extracted modules, so a crafted filename containing overlapping traversal sequences such as ....// collapses to ../ after sanitization and lets the final output path escape the selected output directory, allowing an attacker who can cause a user to run wakaru --unpack on a malicious bundle to write files outside that directory and, depending on the target path and environment, potentially achieve code execution. This issue is fixed in @wakaru/cli 1.4.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-54545?

2 open source packages ship an affected version, including @wakaru/cli.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@wakaru/cli` | npm | From 1.0.0 | 1.4.0 |
| `@wakaru/cli` | npm | From 1.0.0 | 1.4.0 |

## How do I fix CVE-2026-54545?

Upgrade @wakaru/cli to 1.4.0 or later.

## Is CVE-2026-54545 being exploited?

There is no known exploitation of CVE-2026-54545 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54545 and fix it if it is affected.

What it is: CVE-2026-54545 is a high-severity path traversal vulnerability in pionxzh wakaru, published on 28 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-54545 in the wild and no public exploit code.

Affected packages and fixed versions:
- @wakaru/cli (npm): affected from 1.0.0; fixed in 1.4.0
- @wakaru/cli (npm): affected from 1.0.0; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54545/ (Markdown: https://insights.sbomify.com/CVE-2026-54545/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54545
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54545
- OSV: https://osv.dev/vulnerability/CVE-2026-54545

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54545/
Summaries are generated and may contain mistakes; the official description above is the record.
