# CVE-2026-54548: kas: Persistent SSH Host Key Checking Disablement

> kas disables SSH host key checking globally, allowing man-in-the-middle attacks on subsequent SSH sessions for the local user.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Aug 2026
- **Updated:** 26 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-54548, GHSA-mv8m-v9v6-5f94, PYSEC-2026-3855, UBUNTU-CVE-2026-54548

## What is CVE-2026-54548?

CVE-2026-54548 is a low-severity vulnerability in siemens kas, published on 26 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

kas is a setup tool for bitbake based projects. Prior to 5.4, internal SSH key setup triggered by SSH_PRIVATE_KEY or SSH_PRIVATE_KEY_FILE creates ~/.ssh/config when no user-specific SSH configuration exists and adds a global Host * rule containing StrictHostKeyChecking no. In kas/libcmds.py, ssh_no_host_key_check() runs without checking ctx.managed_env, so the setting persists after kas exits and affects future SSH sessions by the same local user, extending beyond the intended short-lived continuous integration environment. A later SSH connection can therefore accept an attacker-controlled host key without verification, increasing the risk of a man-in-the-middle attack that compromises session confidentiality or integrity. This issue is fixed in version 5.4.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-54548?

3 open source packages ship an affected version, including kas.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kas` | PyPI | All versions | 5.4 |
| `kas` | PyPI | All versions | 5.4 |
| `kas` | PyPI | All versions | 5.4 |

## How do I fix CVE-2026-54548?

Upgrade kas to 5.4 or later.

## Is CVE-2026-54548 being exploited?

There is no known exploitation of CVE-2026-54548 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54548 and fix it if it is affected.

What it is: CVE-2026-54548 is a low-severity vulnerability in siemens kas, published on 26 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-54548 in the wild and no public exploit code.

Affected packages and fixed versions:
- kas (PyPI): affected all versions; fixed in 5.4
- kas (PyPI): affected all versions; fixed in 5.4
- kas (PyPI): affected all versions; fixed in 5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54548/ (Markdown: https://insights.sbomify.com/CVE-2026-54548/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54548
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54548
- OSV: https://osv.dev/vulnerability/CVE-2026-54548

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54548/
Summaries are generated and may contain mistakes; the official description above is the record.
