# CVE-2026-54556: Http4s: HTTP/2 Denial of Service with Ember Backend

> An unauthenticated attacker can cause an out-of-memory denial of service in Http4s Ember backend by exploiting HPACK header expansion flaws.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2026
- **Updated:** 29 Aug 2026
- **Also known as:** GHSA-vmm3-xgcx-67hm

## What is CVE-2026-54556?

CVE-2026-54556 is a high-severity denial of service vulnerability in http4s, published on 26 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Http4s is a Scala interface for HTTP services. Prior to 0.23.35 and 1.0.0-M47, an unauthenticated HTTP/2 peer can cause an out-of-memory denial of service in the Ember backend with HTTP/2 enabled. The Hpack wrapper in ember-core/shared/src/main/scala/org/http4s/ember/core/h2/Hpack.scala concatenates HEADERS and CONTINUATION frame fragments and decodes them into a single List, but maxHeaderSize accounting does not include indexed headers or HPACK per-header overhead. A small compressed header block can therefore expand into a much larger decoded representation that remains in memory for processing. Servers exposed to untrusted HTTP/2 traffic and clients directed to an untrusted HTTP/2 server are affected, and concurrent malicious connections can exhaust the process heap. This issue is fixed in versions 0.23.35 and 1.0.0-M47.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-54556?

10 open source packages ship an affected version, including org.http4s:http4s-ember-core_2.13, org.http4s:http4s-ember-core_2.12 and org.http4s:http4s-ember-core_3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.http4s:http4s-ember-core_2.13` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-core_2.13` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-core_2.13` | Maven | From 1.0.0-M1 | 1.0.0-M47 |
| `org.http4s:http4s-ember-core_2.13` | Maven | From 1.0.0-M1 | 1.0.0-M47 |
| `org.http4s:http4s-ember-core_2.12` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-core_2.12` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-core_3` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-core_3` | Maven | All versions | 0.23.35 |
| `org.http4s:http4s-ember-core_3` | Maven | From 1.0.0-M1 | 1.0.0-M47 |
| `org.http4s:http4s-ember-core_3` | Maven | From 1.0.0-M1 | 1.0.0-M47 |

## How do I fix CVE-2026-54556?

Upgrade org.http4s:http4s-ember-core_2.13 to a fixed version for your release line: 0.23.35 or 1.0.0-M47.

## Is CVE-2026-54556 being exploited?

There is no known exploitation of CVE-2026-54556 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54556 and fix it if it is affected.

What it is: CVE-2026-54556 is a high-severity denial of service vulnerability in http4s, published on 26 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54556 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.http4s:http4s-ember-core_2.13 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-core_2.13 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-core_2.13 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47
- org.http4s:http4s-ember-core_2.13 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47
- org.http4s:http4s-ember-core_2.12 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-core_2.12 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-core_3 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-core_3 (Maven): affected all versions; fixed in 0.23.35
- org.http4s:http4s-ember-core_3 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47
- org.http4s:http4s-ember-core_3 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M47

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54556/ (Markdown: https://insights.sbomify.com/CVE-2026-54556/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54556
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54556
- OSV: https://osv.dev/vulnerability/CVE-2026-54556

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54556/
Summaries are generated and may contain mistakes; the official description above is the record.
