# CVE-2026-54557: mise HTTP backend uses raw version path for install symlink destination

> Attackers can use a malicious .tool-versions file to create symlinks outside the install directory, potentially leading to code execution or privilege escalation.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** GHSA-f94h-j2qg-fxw3

## What is CVE-2026-54557?

CVE-2026-54557 is a medium-severity path traversal vulnerability in jdx mise, published on 26 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

mise manages dev tools like node, python, cmake, and terraform. Prior to 2026.6.1, the mise HTTP backend builds its install symlink destination from the raw resolved version string for non-latest versions. Normal tool install paths use the sanitized version pathname, but the HTTP backend's symlink path uses the raw value. On Unix-like systems, if that version is an absolute path, PathBuf::join discards the intended mise installs root. A repository-controlled .tool-versions file can therefore make mise install create a symlink outside the mise install tree. With bin_path, the same issue can place an executable symlink under an attacker-selected absolute prefix, such as a developer-tool prefix that is later added to PATH. This vulnerability is fixed in 2026.6.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-54557?

2 open source packages ship an affected version, including mise.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mise` | crates.io | All versions | 2026.6.1 |
| `mise` | crates.io | All versions | 2026.6.1 |

## How do I fix CVE-2026-54557?

Upgrade mise to 2026.6.1 or later.

## Is CVE-2026-54557 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54557 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54557 and fix it if it is affected.

What it is: CVE-2026-54557 is a medium-severity path traversal vulnerability in jdx mise, published on 26 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54557 exists.

Affected packages and fixed versions:
- mise (crates.io): affected all versions; fixed in 2026.6.1
- mise (crates.io): affected all versions; fixed in 2026.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54557/ (Markdown: https://insights.sbomify.com/CVE-2026-54557/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54557
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54557
- OSV: https://osv.dev/vulnerability/CVE-2026-54557

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54557/
Summaries are generated and may contain mistakes; the official description above is the record.
