{"answers":{"affected":"3 open source packages ship an affected version, including pocketsphinx.","exploited":"There is no known exploitation of CVE-2026-54559 in the wild and no public exploit code.","fix":"Upgrade pocketsphinx to 5.1.1 or later.","what":"CVE-2026-54559 is a medium-severity memory corruption vulnerability in cmusphinx pocketsphinx, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-54559 and fix it if it is affected.\n\nWhat it is: CVE-2026-54559 is a medium-severity memory corruption vulnerability in cmusphinx pocketsphinx, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-54559 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pocketsphinx (PyPI): affected all versions; fixed in 5.1.1\n- pocketsphinx (PyPI): affected all versions; fixed in 5.1.1\n- pocketsphinx (PyPI): affected all versions; fixed in 5.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54559/ (Markdown: https://insights.sbomify.com/CVE-2026-54559/index.md)","id":"CVE-2026-54559","markdown":"https://insights.sbomify.com/CVE-2026-54559/index.md","name":"CVE-2026-54559","record":{"aliases":["GHSA-56r5-2p2f-7cxp","PYSEC-2026-3498","UBUNTU-CVE-2026-54559"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Speech recognition library","requires_auth":"none","summary":"Attackers can trigger buffer overflows and memory corruption by providing malicious speech model files, potentially leading to code execution or crashes.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"},{"id":"CWE-121","name":"Stack-based Buffer Overflow"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"PocketSphinx is a small speech recognizer. Prior to 5.1.1, the trie language-model loaders in src/lm/ngram_model_trie.c do not adequately validate boundary conditions in ARPA, DMP, and binary format headers, and the acoustic-model loaders in src/mdef.c and src/util/bio.c use sscanf with unbounded string fields. Loading an invalid, corrupted, or malicious language or acoustic model can therefore cause stack or heap buffer overflows and memory corruption. An attacker who can write to a directory selected by POCKETSPHINX_PATH can replace or add a model file that PocketSphinx later loads; users of PocketSphinx 5prealpha have no backported patch and must migrate to the fixed release. This issue is fixed in version 5.1.1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PocketSphinx: Buffer overflows in language and acoustic model loading code","id":"CVE-2026-54559","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Cloudreve: OAuth access tokens bypass scope enforcement due to missing client_id claim","id":"CVE-2026-54560"},"packages":[{"ecosystem":"PyPI","fixed":["5.1.1"],"introduced":["0"],"last_affected":[],"package":"pocketsphinx","purl":null,"source":"GHSA-56r5-2p2f-7cxp"},{"ecosystem":"PyPI","fixed":["5.1.1"],"introduced":["0"],"last_affected":[],"package":"pocketsphinx","purl":"pkg:pypi/pocketsphinx","source":"GHSA-56r5-2p2f-7cxp"},{"ecosystem":"PyPI","fixed":["5.1.1"],"introduced":["0"],"last_affected":[],"package":"pocketsphinx","purl":"pkg:pypi/pocketsphinx","source":"PYSEC-2026-3498"}],"prev":{"headline":"mise HTTP backend uses raw version path for install symlink destination","id":"CVE-2026-54557"},"products":["pocketsphinx"],"published":"2026-09-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-15","vendors":["cmusphinx"]},"summary":"Attackers can trigger buffer overflows and memory corruption by providing malicious speech model files, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/CVE-2026-54559/"}