# CVE-2026-54559: PocketSphinx: Buffer overflows in language and acoustic model loading code

> Attackers can trigger buffer overflows and memory corruption by providing malicious speech model files, potentially leading to code execution or crashes.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-56r5-2p2f-7cxp, PYSEC-2026-3498, UBUNTU-CVE-2026-54559

## What is CVE-2026-54559?

CVE-2026-54559 is a medium-severity memory corruption vulnerability in cmusphinx pocketsphinx, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PocketSphinx is a small speech recognizer. Prior to 5.1.1, the trie language-model loaders in src/lm/ngram_model_trie.c do not adequately validate boundary conditions in ARPA, DMP, and binary format headers, and the acoustic-model loaders in src/mdef.c and src/util/bio.c use sscanf with unbounded string fields. Loading an invalid, corrupted, or malicious language or acoustic model can therefore cause stack or heap buffer overflows and memory corruption. An attacker who can write to a directory selected by POCKETSPHINX_PATH can replace or add a model file that PocketSphinx later loads; users of PocketSphinx 5prealpha have no backported patch and must migrate to the fixed release. This issue is fixed in version 5.1.1.

Weakness: CWE-122 (Heap-based Buffer Overflow), CWE-121 (Stack-based Buffer Overflow), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2026-54559?

3 open source packages ship an affected version, including pocketsphinx.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pocketsphinx` | PyPI | All versions | 5.1.1 |
| `pocketsphinx` | PyPI | All versions | 5.1.1 |
| `pocketsphinx` | PyPI | All versions | 5.1.1 |

## How do I fix CVE-2026-54559?

Upgrade pocketsphinx to 5.1.1 or later.

## Is CVE-2026-54559 being exploited?

There is no known exploitation of CVE-2026-54559 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54559 and fix it if it is affected.

What it is: CVE-2026-54559 is a medium-severity memory corruption vulnerability in cmusphinx pocketsphinx, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54559 in the wild and no public exploit code.

Affected packages and fixed versions:
- pocketsphinx (PyPI): affected all versions; fixed in 5.1.1
- pocketsphinx (PyPI): affected all versions; fixed in 5.1.1
- pocketsphinx (PyPI): affected all versions; fixed in 5.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54559/ (Markdown: https://insights.sbomify.com/CVE-2026-54559/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54559
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54559
- OSV: https://osv.dev/vulnerability/CVE-2026-54559

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54559/
Summaries are generated and may contain mistakes; the official description above is the record.
