# CVE-2026-54563: Cloudreve WebDAV (`/dav`) has Path Traversal / Broken Access Control — scoped DAV credential escapes its configured account root

> Attackers with scoped WebDAV credentials can escape their configured root directory to read, modify, or delete files outside the intended scope.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-w5fv-7x5q-g8qp, GO-2026-6298

## What is CVE-2026-54563?

CVE-2026-54563 is a high-severity path traversal vulnerability in cloudreve, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cloudreve is a self-hosted file management and sharing system. Prior to 4.16.1, a Cloudreve WebDAV account rooted at a configured folder can send paths such as /dav/%2e%2e/outside.txt because stripPrefix in pkg/webdav/webdav.go joins the decoded request suffix to the account root with fs.URI.JoinRaw without checking containment, allowing the scoped credential to read and list files outside the configured folder and writable credentials to create, overwrite, move, or delete them. This issue is reported as fixed in version 4.16.1.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-54563?

7 open source packages ship an affected version, including github.com/cloudreve/Cloudreve/v3, github.com/cloudreve/Cloudreve and github.com/cloudreve/Cloudreve/v4.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cloudreve/Cloudreve/v3` | Go | All versions | None |
| `github.com/cloudreve/Cloudreve/v3` | Go | All versions to 3.0.0-20250225100611-da4e44b77af4 | None |
| `github.com/cloudreve/Cloudreve/v3` | Go | All versions to 3.0.0-20250225100611-da4e44b77af4 | None |
| `github.com/cloudreve/Cloudreve` | Go | All versions | None |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.0.0-20260606032813-26b6b1044b02 |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.0.0-20260606032813-26b6b1044b02 |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.0.0-20260606032813-26b6b1044b02 |

## How do I fix CVE-2026-54563?

Upgrade to a fixed version.

## Is CVE-2026-54563 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54563 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54563 and fix it if it is affected.

What it is: CVE-2026-54563 is a high-severity path traversal vulnerability in cloudreve, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54563 exists.

Affected packages and fixed versions:
- github.com/cloudreve/Cloudreve/v3 (Go): affected all versions; no fix listed
- github.com/cloudreve/Cloudreve/v3 (Go): affected all versions up to 3.0.0-20250225100611-da4e44b77af4; no fix listed
- github.com/cloudreve/Cloudreve/v3 (Go): affected all versions up to 3.0.0-20250225100611-da4e44b77af4; no fix listed
- github.com/cloudreve/Cloudreve (Go): affected all versions; no fix listed
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.0.0-20260606032813-26b6b1044b02
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.0.0-20260606032813-26b6b1044b02
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.0.0-20260606032813-26b6b1044b02

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54563/ (Markdown: https://insights.sbomify.com/CVE-2026-54563/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54563
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54563
- OSV: https://osv.dev/vulnerability/CVE-2026-54563

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54563/
Summaries are generated and may contain mistakes; the official description above is the record.
