# CVE-2026-54573: Authorization Bypass in API Key/OAuth Scopes via Path Parsing Discrepancy

> Attackers can bypass API key scope restrictions by appending fragments to URLs, allowing unauthorized access to restricted endpoints and privilege escalation.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** GHSA-5x79-rj4g-qrh8

## What is CVE-2026-54573?

CVE-2026-54573 is a medium-severity authentication bypass vulnerability in outline, published on 25 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Outline is a service that allows for collaborative documentation. Prior to 1.8.0, the AuthenticationHelper.canAccess function uses ctx.originalUrl to verify if an API key or OAuth token has the required scopes for a request. It extracts the resource by splitting the URL by / and taking the last segment. However, it fails to strip the URL fragment (#). Because Koa's router uses ctx.path (which strips the fragment) for routing, an attacker can append a fragment containing a permitted path (e.g., #foo/api/documents.info) to a restricted endpoint (e.g., /api/documents.create). The router will route the request to the restricted endpoint, but canAccess will evaluate the permitted path in the fragment, bypassing the API key scope restrictions and allowing privilege escalation. This vulnerability is fixed in 1.8.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-54573?


## How do I fix CVE-2026-54573?

No fix has been published for CVE-2026-54573 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54573 being exploited?

There is no known exploitation of CVE-2026-54573 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54573 and fix it if it is affected.

What it is: CVE-2026-54573 is a medium-severity authentication bypass vulnerability in outline, published on 25 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54573 in the wild and no public exploit code.

Affected product: outline. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54573/ (Markdown: https://insights.sbomify.com/CVE-2026-54573/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54573
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54573
- OSV: https://osv.dev/vulnerability/CVE-2026-54573

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54573/
Summaries are generated and may contain mistakes; the official description above is the record.
