# CVE-2026-54574: `proot-distro install` has a Symlink Escape (Arbitrary Host File Write) via Malicious Tar Archive

> A malicious tar archive can exploit symlink handling in proot-distro to write arbitrary files to the host filesystem, potentially leading to code execution.

- **Severity:** High 8.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-9xq3-3fqg-4vg7, PYSEC-2026-3608

## What is CVE-2026-54574?

CVE-2026-54574 is a high-severity path traversal vulnerability in termux proot-distro, published on 29 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

proot-distro is a utility for managing proot containers. Prior to version 5.1.5, proot-distro install extracted plain tarball root filesystems through _extract_plain_tar() in proot_distro/commands/install.py and Docker layers through _apply_layer() in proot_distro/helpers/docker.py without validating archive-controlled symlink targets in member.linkname, allowing a malicious archive to plant an absolute host-path symlink and write files through it onto the host filesystem. This issue is fixed in version 5.1.5.

Weakness: CWE-61 (UNIX Symbolic Link (Symlink) Following)

## Which versions are affected by CVE-2026-54574?

3 open source packages ship an affected version, including proot-distro.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `proot-distro` | PyPI | All versions | 5.1.5 |
| `proot-distro` | PyPI | All versions | 5.1.5 |
| `proot-distro` | PyPI | All versions | 5.1.5 |

## How do I fix CVE-2026-54574?

Upgrade proot-distro to 5.1.5 or later.

## Is CVE-2026-54574 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54574 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54574 and fix it if it is affected.

What it is: CVE-2026-54574 is a high-severity path traversal vulnerability in termux proot-distro, published on 29 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54574 exists.

Affected packages and fixed versions:
- proot-distro (PyPI): affected all versions; fixed in 5.1.5
- proot-distro (PyPI): affected all versions; fixed in 5.1.5
- proot-distro (PyPI): affected all versions; fixed in 5.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54574/ (Markdown: https://insights.sbomify.com/CVE-2026-54574/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54574
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54574
- OSV: https://osv.dev/vulnerability/CVE-2026-54574

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54574/
Summaries are generated and may contain mistakes; the official description above is the record.
