# CVE-2026-54577: mport audit can inspect the wrong package when options are present

> The mport audit command may inspect the wrong package when options are used, potentially leaving vulnerable packages unidentified.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** GHSA-h3m9-vj4v-c35h

## What is CVE-2026-54577?

CVE-2026-54577 is a low-severity vulnerability in MidnightBSD mport, published on 17 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

mport is the MidnightBSD Package Manager. Prior to 2.7.8, the audit command in mport/mport.c computed option-adjusted local_argv and local_argc values but passed the original argument entry to audit_package(). When an operator or automation used an option such as -r before a package name, stale optind state and the unadjusted argument could cause mport to audit the option token instead of the requested package, producing a false-negative or useless result that could leave a vulnerable package unidentified. The corrected parsing resets optind and optreset before using the adjusted local arguments. This issue is fixed in version 2.7.8.

Weakness: CWE-693 (Protection Mechanism Failure), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-54577?


## How do I fix CVE-2026-54577?

No fix has been published for CVE-2026-54577 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54577 being exploited?

There is no known exploitation of CVE-2026-54577 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54577 and fix it if it is affected.

What it is: CVE-2026-54577 is a low-severity vulnerability in MidnightBSD mport, published on 17 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54577 in the wild and no public exploit code.

Affected product: MidnightBSD mport. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54577/ (Markdown: https://insights.sbomify.com/CVE-2026-54577/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54577
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54577
- OSV: https://osv.dev/vulnerability/CVE-2026-54577

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54577/
Summaries are generated and may contain mistakes; the official description above is the record.
