# CVE-2026-54580: mport index decompression can leave partial or corrupt index data after zstd failures

> A malicious mirror can cause package index corruption or denial of service in MidnightBSD's mport by exploiting improper error handling in zstd decompression.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** GHSA-ffqj-j42r-747w

## What is CVE-2026-54580?

CVE-2026-54580 is a high-severity denial of service vulnerability in MidnightBSD mport, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

mport is the MidnightBSD Package Manager. Prior to 2.7.8, libmport/util.c did not make every truncated, corrupt, or failed zstd stream fatal in mport_decompress_zstd(), and libmport/fetch.c did not consistently propagate those failures to index-fetch callers. A malicious or faulty mirror could supply compressed package index data that caused ZSTD_decompressStream() or an output write to fail while leaving partial index output available for later use, resulting in package-index integrity loss or denial of service. This issue is fixed in version 2.7.8.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions), CWE-354 (Improper Validation of Integrity Check Value)

## Which versions are affected by CVE-2026-54580?


## How do I fix CVE-2026-54580?

No fix has been published for CVE-2026-54580 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54580 being exploited?

There is no known exploitation of CVE-2026-54580 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54580 and fix it if it is affected.

What it is: CVE-2026-54580 is a high-severity denial of service vulnerability in MidnightBSD mport, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54580 in the wild and no public exploit code.

Affected product: MidnightBSD mport. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54580/ (Markdown: https://insights.sbomify.com/CVE-2026-54580/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54580
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54580
- OSV: https://osv.dev/vulnerability/CVE-2026-54580

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54580/
Summaries are generated and may contain mistakes; the official description above is the record.
