# CVE-2026-54582: mport package installation can overwrite existing unmanaged or differently owned files

> A crafted package can overwrite existing files during installation if force mode is enabled, compromising filesystem integrity and potentially allowing privilege escalation.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-5773-7r4r-rpgx

## What is CVE-2026-54582?

CVE-2026-54582 is a medium-severity path traversal vulnerability in MidnightBSD mport, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

mport is the MidnightBSD Package Manager. Prior to 2.7.8, package installation lacked a preflight check for incoming non-directory assets that already existed on disk. The affected logic across libmport/check_preconditions.c, libmport/install_primative.c, and libmport/mport_private.h did not apply MPORT_PRECHECK_FILE_CONFLICTS, so a crafted or conflicting package could overwrite a file owned by another package or unmanaged by mport. The check is bypassed only when the operator explicitly enables mport->force. Privileged installation without that override could compromise local filesystem integrity and package database consistency. This issue is fixed in version 2.7.8.

Weakness: CWE-73 (External Control of File Name or Path), CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2026-54582?


## How do I fix CVE-2026-54582?

No fix has been published for CVE-2026-54582 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54582 being exploited?

There is no known exploitation of CVE-2026-54582 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54582 and fix it if it is affected.

What it is: CVE-2026-54582 is a medium-severity path traversal vulnerability in MidnightBSD mport, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-54582 in the wild and no public exploit code.

Affected product: MidnightBSD mport. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54582/ (Markdown: https://insights.sbomify.com/CVE-2026-54582/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54582
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54582
- OSV: https://osv.dev/vulnerability/CVE-2026-54582

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54582/
Summaries are generated and may contain mistakes; the official description above is the record.
