# CVE-2026-54587: mport directory asset installation is vulnerable to symlink and path traversal races

> A local attacker can exploit race conditions and path traversal in mport to modify files outside intended directories during privileged package installation.

- **Severity:** Medium 5.8 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-f69w-h3gh-r86p

## What is CVE-2026-54587?

CVE-2026-54587 is a medium-severity path traversal vulnerability in MidnightBSD mport, published on 17 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

mport is the MidnightBSD Package Manager. Prior to 2.7.8, directory assets handled as ASSET_DIR or ASSET_DIR_OWNER_MODE in libmport/bundle_read_install_pkg.c used path-based mport_mkdirp(), ownership, and permission operations. A local attacker able to modify part of the target installation tree could use dot-dot traversal or substitute symlinks during privileged package installation, causing directory creation or attribute changes to affect attacker-selected paths outside the intended package directories. This issue is fixed in version 2.7.8.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-54587?


## How do I fix CVE-2026-54587?

No fix has been published for CVE-2026-54587 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54587 being exploited?

There is no known exploitation of CVE-2026-54587 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54587 and fix it if it is affected.

What it is: CVE-2026-54587 is a medium-severity path traversal vulnerability in MidnightBSD mport, published on 17 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54587 in the wild and no public exploit code.

Affected product: MidnightBSD mport. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54587/ (Markdown: https://insights.sbomify.com/CVE-2026-54587/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54587
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54587
- OSV: https://osv.dev/vulnerability/CVE-2026-54587

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54587/
Summaries are generated and may contain mistakes; the official description above is the record.
