# CVE-2026-54591: AsyncSSH: SCP Path Traversal to Arbitrary File Write

> A malicious SSH server can write arbitrary files on the AsyncSSH SCP client's filesystem via path traversal sequences in filenames.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** CLEANSTART-2026-ZT97378, DEBIAN-CVE-2026-54591, ECHO-ba32-5913-3705, GHSA-2wxc-x7rj-hg8f, MINI-9vjw-g347-8jfv, MINI-fv46-g3fx-9q59, MINI-h6wg-q9ww-xfqr, PYSEC-2026-3808, UBUNTU-CVE-2026-54591

## What is CVE-2026-54591?

CVE-2026-54591 is a high-severity path traversal vulnerability in ronf asyncssh, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

AsyncSSH is a Python package which provides an asynchronous client and server implementation of the SSHv2 protocol on top of the Python asyncio framework. Prior to 2.23.1, a malicious SSH server can write arbitrary files on the asyncssh SCP client's filesystem by sending filenames containing ../ traversal sequences because _parse_cd_args in scp.py returns server-provided names verbatim and _recv_files joins them to the destination path without enforcing the target directory boundary. This issue is fixed in version 2.23.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-54591?

3 open source packages ship an affected version, including asyncssh.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `asyncssh` | PyPI | All versions | 2.23.1 |
| `asyncssh` | PyPI | All versions | 2.23.1 |
| `asyncssh` | PyPI | All versions | 2.23.1 |

## How do I fix CVE-2026-54591?

Upgrade asyncssh to 2.23.1 or later.

## Is CVE-2026-54591 being exploited?

There is no known exploitation of CVE-2026-54591 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54591 and fix it if it is affected.

What it is: CVE-2026-54591 is a high-severity path traversal vulnerability in ronf asyncssh, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-54591 in the wild and no public exploit code.

Affected packages and fixed versions:
- asyncssh (PyPI): affected all versions; fixed in 2.23.1
- asyncssh (PyPI): affected all versions; fixed in 2.23.1
- asyncssh (PyPI): affected all versions; fixed in 2.23.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54591/ (Markdown: https://insights.sbomify.com/CVE-2026-54591/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54591
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54591
- OSV: https://osv.dev/vulnerability/CVE-2026-54591

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54591/
Summaries are generated and may contain mistakes; the official description above is the record.
