{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54601 exists.","fix":"No fix has been published for CVE-2026-54601 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-54601 is a medium-severity missing authorization vulnerability in labring FastGPT, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-54601 and fix it if it is affected.\n\nWhat it is: CVE-2026-54601 is a medium-severity missing authorization vulnerability in labring FastGPT, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54601 exists.\n\nAffected product: labring FastGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54601/ (Markdown: https://insights.sbomify.com/CVE-2026-54601/index.md)","id":"CVE-2026-54601","markdown":"https://insights.sbomify.com/CVE-2026-54601/index.md","name":"CVE-2026-54601","record":{"aliases":["GHSA-qxcq-48gr-93pj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"AI knowledge base platform","requires_auth":"low_privilege","summary":"Authenticated users can override dataset IDs to access and modify other tenants' data due to inconsistent ownership checks.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-915","name":"Improperly Controlled Modification of Dynamically-Determined Object Attributes"}],"description":"FastGPT is an open source AI knowledge base platform. From 4.14.17 to before 4.15.0-beta4, FastGPT allows an authenticated tenant user to call POST /api/core/dataset/collection/create/reTrainingCollection in a way that persists a server-owned datasetId value from another tenant. This creates mixed dataset objects and downstream dataset, collection, and training endpoints then make authorization decisions from inconsistent ownership anchors, allowing cross-tenant read, update, and delete access when mixed object ids are known. This issue is fixed in version 4.15.0-beta4.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"FastGPT: reTrainingCollection allows server-owned datasetId override causing cross-tenant authorization confusion","id":"CVE-2026-54601","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"FastGPT: Cross-team LLM request/response disclosure (IDOR) via /api/core/ai/record/getRecord","id":"CVE-2026-54602"},"packages":[],"prev":{"headline":"Wallos: Unauthenticated database replacement via import endpoint on fresh install","id":"CVE-2026-54600"},"products":["FastGPT"],"published":"2026-07-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-08","vendors":["labring"]},"summary":"Authenticated users can override dataset IDs to access and modify other tenants' data due to inconsistent ownership checks.","url":"https://insights.sbomify.com/CVE-2026-54601/"}