# CVE-2026-54602: FastGPT: Cross-team LLM request/response disclosure (IDOR) via /api/core/ai/record/getRecord

> Authenticated users can read other teams' LLM prompts and responses by accessing a specific API endpoint without proper team scoping.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** GHSA-6vx6-f72r-74cg

## What is CVE-2026-54602?

CVE-2026-54602 is a high-severity missing authorization vulnerability in labring FastGPT, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

FastGPT is a knowledge-based AI application platform. Prior to 4.15.0, GET /api/core/ai/record/getRecord authenticates the caller but loads LLM request and response traces only by requestId without team scoping, allowing any authenticated user to read another team's prompts, retrieved RAG chunks, and completions if the requestId is known. This issue is fixed in version 4.15.0.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-54602?


## How do I fix CVE-2026-54602?

No fix has been published for CVE-2026-54602 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54602 being exploited?

There is no known exploitation of CVE-2026-54602 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54602 and fix it if it is affected.

What it is: CVE-2026-54602 is a high-severity missing authorization vulnerability in labring FastGPT, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54602 in the wild and no public exploit code.

Affected product: labring FastGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54602/ (Markdown: https://insights.sbomify.com/CVE-2026-54602/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54602
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54602
- OSV: https://osv.dev/vulnerability/CVE-2026-54602

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54602/
Summaries are generated and may contain mistakes; the official description above is the record.
