{"answers":{"affected":"2 open source packages ship an affected version, including oauth2.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54603 exists.","fix":"Upgrade oauth2 to 2.0.22 or later.","what":"CVE-2026-54603 is a high-severity vulnerability in ruby-oauth oauth2, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-54603 and fix it if it is affected.\n\nWhat it is: CVE-2026-54603 is a high-severity vulnerability in ruby-oauth oauth2, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54603 exists.\n\nAffected packages and fixed versions:\n- oauth2 (RubyGems): affected from 0.4.0; fixed in 2.0.22\n- oauth2 (RubyGems): affected from 0.4.0; fixed in 2.0.22\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54603/ (Markdown: https://insights.sbomify.com/CVE-2026-54603/index.md)","id":"CVE-2026-54603","markdown":"https://insights.sbomify.com/CVE-2026-54603/index.md","name":"CVE-2026-54603","record":{"aliases":["DEBIAN-CVE-2026-54603","GHSA-pp92-crg2-gfv9","UBUNTU-CVE-2026-54603"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby OAuth2 library","requires_auth":"none","summary":"Attackers can leak bearer tokens to malicious hosts via protocol-relative redirects in the Ruby OAuth2 library, compromising user credentials.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"OAuth2 is a Ruby wrapper for the OAuth 2.0 and 2.1 authorization frameworks, including OpenID Connect (OIDC). From 0.4.0 to 2.0.21, a protocol-relative redirect Location returned to OAuth2::Client#request overrides the request authority, so the bearer Authorization header is sent to an attacker-controlled host, leaking the credential. This issue is fixed in version 2.0.22.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"OAuth2::Client#request: Protocol-relative redirect Location overrides authority, leaking bearer Authorization to attacker host","id":"CVE-2026-54603","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"OpenSlide: openslide_read_region() returns uninitialized memory with libtiff 4.7.1","id":"CVE-2026-54604"},"packages":[{"ecosystem":"RubyGems","fixed":["2.0.22"],"introduced":["0.4.0"],"last_affected":[],"package":"oauth2","purl":null,"source":"GHSA-pp92-crg2-gfv9"},{"ecosystem":"RubyGems","fixed":["2.0.22"],"introduced":["0.4.0"],"last_affected":[],"package":"oauth2","purl":"pkg:gem/oauth2","source":"GHSA-pp92-crg2-gfv9"}],"prev":{"headline":"FastGPT: Cross-team LLM request/response disclosure (IDOR) via /api/core/ai/record/getRecord","id":"CVE-2026-54602"},"products":["oauth2"],"published":"2026-07-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-05","vendors":["ruby-oauth"]},"summary":"Attackers can leak bearer tokens to malicious hosts via protocol-relative redirects in the Ruby OAuth2 library, compromising user credentials.","url":"https://insights.sbomify.com/CVE-2026-54603/"}