# CVE-2026-54603: OAuth2::Client#request: Protocol-relative redirect Location overrides authority, leaking bearer Authorization to attacker host

> Attackers can leak bearer tokens to malicious hosts via protocol-relative redirects in the Ruby OAuth2 library, compromising user credentials.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 5 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-54603, GHSA-pp92-crg2-gfv9, UBUNTU-CVE-2026-54603

## What is CVE-2026-54603?

CVE-2026-54603 is a high-severity vulnerability in ruby-oauth oauth2, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OAuth2 is a Ruby wrapper for the OAuth 2.0 and 2.1 authorization frameworks, including OpenID Connect (OIDC). From 0.4.0 to 2.0.21, a protocol-relative redirect Location returned to OAuth2::Client#request overrides the request authority, so the bearer Authorization header is sent to an attacker-controlled host, leaking the credential. This issue is fixed in version 2.0.22.

Weakness: CWE-601 (URL Redirection to Untrusted Site), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-54603?

2 open source packages ship an affected version, including oauth2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oauth2` | RubyGems | From 0.4.0 | 2.0.22 |
| `oauth2` | RubyGems | From 0.4.0 | 2.0.22 |

## How do I fix CVE-2026-54603?

Upgrade oauth2 to 2.0.22 or later.

## Is CVE-2026-54603 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54603 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54603 and fix it if it is affected.

What it is: CVE-2026-54603 is a high-severity vulnerability in ruby-oauth oauth2, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54603 exists.

Affected packages and fixed versions:
- oauth2 (RubyGems): affected from 0.4.0; fixed in 2.0.22
- oauth2 (RubyGems): affected from 0.4.0; fixed in 2.0.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54603/ (Markdown: https://insights.sbomify.com/CVE-2026-54603/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54603
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54603
- OSV: https://osv.dev/vulnerability/CVE-2026-54603

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54603/
Summaries are generated and may contain mistakes; the official description above is the record.
