# CVE-2026-54604: OpenSlide: openslide_read_region() returns uninitialized memory with libtiff 4.7.1


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-54604, GHSA-f734-jv98-5677, UBUNTU-CVE-2026-54604

## What is CVE-2026-54604?

CVE-2026-54604 is a medium-severity vulnerability in openslide, published on 17 Sep 2026. 

### Official description

OpenSlide is a C library for reading whole slide image files. Prior to 4.0.1, a behavior change in libtiff 4.7.1 causes the indirect TIFF tile path in src/openslide-decode-tiff.c and _openslide_tiff_read_tile() to request a full-height destination for a partial bottom tile row, allowing uninitialized heap memory to enter pixel data returned by openslide_read_region(). A crafted but valid slide can trigger the issue in TIFF-based formats other than Hamamatsu NDPI when a network service renders attacker-provided slides. Successful extraction depends on pixel transparency handling and recompression, OpenSlide with libtiff 4.7.0 or earlier is not affected, and official binary builds 4.0.0.10 and 4.0.0.11 are affected. This issue is fixed in OpenSlide 4.0.1 and official binary build 4.0.0.12.

Weakness: CWE-908 (Use of Uninitialized Resource), CWE-758 (Reliance on Undefined, Unspecified, or Implementation-Defined Behavior)

## Which versions are affected by CVE-2026-54604?


## How do I fix CVE-2026-54604?

Upgrade to a fixed version.

## Is CVE-2026-54604 being exploited?

There is no known exploitation of CVE-2026-54604 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54604 and fix it if it is affected.

What it is: CVE-2026-54604 is a medium-severity vulnerability in openslide, published on 17 Sep 2026. 
Exploitation: There is no known exploitation of CVE-2026-54604 in the wild and no public exploit code.

Affected product: openslide. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54604/ (Markdown: https://insights.sbomify.com/CVE-2026-54604/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54604
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54604
- OSV: https://osv.dev/vulnerability/CVE-2026-54604

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54604/
Summaries are generated and may contain mistakes; the official description above is the record.
