{"answers":{"affected":"2 open source packages ship an affected version, including oauth.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54605 exists.","fix":"Upgrade oauth to 1.1.6 or later.","what":"CVE-2026-54605 is a high-severity server-side request forgery vulnerability in ruby-oauth oauth, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-54605 and fix it if it is affected.\n\nWhat it is: CVE-2026-54605 is a high-severity server-side request forgery vulnerability in ruby-oauth oauth, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54605 exists.\n\nAffected packages and fixed versions:\n- oauth (RubyGems): affected from 0.5.5; fixed in 1.1.6\n- oauth (RubyGems): affected from 0.5.5; fixed in 1.1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54605/ (Markdown: https://insights.sbomify.com/CVE-2026-54605/index.md)","id":"CVE-2026-54605","markdown":"https://insights.sbomify.com/CVE-2026-54605/index.md","name":"CVE-2026-54605","record":{"aliases":["GHSA-prq8-7wvh-44qh","UBUNTU-CVE-2026-54605"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby OAuth library","requires_auth":"none","summary":"Attackers can expose signed OAuth request metadata to cross-origin hosts via malicious redirects in the Ruby OAuth library.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-346","name":"Origin Validation Error"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"OAuth is a Ruby wrapper for the OAuth 1.0 and 1.0a protocols, providing clients and servers. From 0.5.5 to 1.1.5, OAuth::Consumer#token_request parses the raw Location header of a 300 to 399 redirect returned by the OAuth server and follows the redirect recursively, which can mutate the consumer's configuration and expose signed OAuth request metadata, including the Authorization header, to a cross-origin host. This issue is fixed in version 1.1.6.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"OAuth: Cross-origin token-request redirects can expose signed request metadata","id":"CVE-2026-54605","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"SunEditor: DOM XSS in SunEditor Embed Plugin via External Script Element After Iframe Embed","id":"CVE-2026-54606"},"packages":[{"ecosystem":"RubyGems","fixed":["1.1.6"],"introduced":["0.5.5"],"last_affected":[],"package":"oauth","purl":null,"source":"GHSA-prq8-7wvh-44qh"},{"ecosystem":"RubyGems","fixed":["1.1.6"],"introduced":["0.5.5"],"last_affected":[],"package":"oauth","purl":"pkg:gem/oauth","source":"GHSA-prq8-7wvh-44qh"}],"prev":{"headline":"OpenSlide: openslide_read_region() returns uninitialized memory with libtiff 4.7.1","id":"CVE-2026-54604"},"products":["oauth"],"published":"2026-07-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-28","vendors":["ruby-oauth"]},"summary":"Attackers can expose signed OAuth request metadata to cross-origin hosts via malicious redirects in the Ruby OAuth library.","url":"https://insights.sbomify.com/CVE-2026-54605/"}