# CVE-2026-54605: OAuth: Cross-origin token-request redirects can expose signed request metadata

> Attackers can expose signed OAuth request metadata to cross-origin hosts via malicious redirects in the Ruby OAuth library.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** GHSA-prq8-7wvh-44qh, UBUNTU-CVE-2026-54605

## What is CVE-2026-54605?

CVE-2026-54605 is a high-severity server-side request forgery vulnerability in ruby-oauth oauth, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OAuth is a Ruby wrapper for the OAuth 1.0 and 1.0a protocols, providing clients and servers. From 0.5.5 to 1.1.5, OAuth::Consumer#token_request parses the raw Location header of a 300 to 399 redirect returned by the OAuth server and follows the redirect recursively, which can mutate the consumer's configuration and expose signed OAuth request metadata, including the Authorization header, to a cross-origin host. This issue is fixed in version 1.1.6.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-346 (Origin Validation Error), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-54605?

2 open source packages ship an affected version, including oauth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oauth` | RubyGems | From 0.5.5 | 1.1.6 |
| `oauth` | RubyGems | From 0.5.5 | 1.1.6 |

## How do I fix CVE-2026-54605?

Upgrade oauth to 1.1.6 or later.

## Is CVE-2026-54605 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54605 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54605 and fix it if it is affected.

What it is: CVE-2026-54605 is a high-severity server-side request forgery vulnerability in ruby-oauth oauth, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54605 exists.

Affected packages and fixed versions:
- oauth (RubyGems): affected from 0.5.5; fixed in 1.1.6
- oauth (RubyGems): affected from 0.5.5; fixed in 1.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54605/ (Markdown: https://insights.sbomify.com/CVE-2026-54605/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54605
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54605
- OSV: https://osv.dev/vulnerability/CVE-2026-54605

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54605/
Summaries are generated and may contain mistakes; the official description above is the record.
