# CVE-2026-54607: FastGPT: SSRF in HTTP-tool OpenAPI schema importer via SwaggerParser $ref (bypasses the isInternalAddress guard)

> Authenticated users can exploit an SSRF vulnerability in the OpenAPI importer to read internal services or cloud metadata by bypassing address guards.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** GHSA-72hf-5382-2mq9

## What is CVE-2026-54607?

CVE-2026-54607 is a high-severity server-side request forgery vulnerability in labring FastGPT, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

FastGPT is a knowledge-based AI application platform. Prior to 4.15.0-beta4, the HTTP-tool OpenAPI schema importer validates only the top-level URL before passing it to SwaggerParser.bundle, whose remote reference resolver fetches $ref URLs without FastGPT's internal-address guard and returns fetched content inline, allowing an authenticated team member to read internal services or cloud metadata. This issue is fixed in version 4.15.0-beta4.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-54607?


## How do I fix CVE-2026-54607?

No fix has been published for CVE-2026-54607 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54607 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54607 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54607 and fix it if it is affected.

What it is: CVE-2026-54607 is a high-severity server-side request forgery vulnerability in labring FastGPT, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54607 exists.

Affected product: labring FastGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54607/ (Markdown: https://insights.sbomify.com/CVE-2026-54607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54607
- OSV: https://osv.dev/vulnerability/CVE-2026-54607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54607/
Summaries are generated and may contain mistakes; the official description above is the record.
