CVE-2026-54614 DebugKit: MailPreview contains unsafe reflection
Attackers with local or allowlisted access can trigger arbitrary constructor execution via unsafe reflection in DebugKit's MailPreview feature, leading to code execution and data disclosure.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-54614?
CVE-2026-54614 is a medium-severity code injection vulnerability in cakephp debug_kit, published on 26 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
DebugKit provides a debugging toolbar for CakePHP applications. Prior to 4.10.3 and 5.2.4, the DebugKit MailPreview feature in src/Controller/MailPreviewController.php accepts a route-controlled previewName value in findPreview and passes the resolved class from App::className() to constructor execution without rejecting namespace separators or verifying that the class extends DebugKit\Mailer\MailPreview. An attacker able to access DebugKit while debug mode is enabled and the request hostname is local or allowlisted can select an unintended application class through the mail-preview preview route, resulting in arbitrary constructor execution and limited disclosure of application information. This issue is fixed in versions 4.10.3 and 5.2.4.
Weakness: CWE-470
Which versions are affected by CVE-2026-54614?
4 open source packages ship an affected version, including cakephp/debug_kit.
| Package | Affected | Fixed in |
|---|---|---|
cakephp/debug_kit Packagist | All versions | 4.10.3 |
cakephp/debug_kit Packagist | All versions | 4.10.3 |
cakephp/debug_kit Packagist | From 5.0.0 | 5.2.4 |
cakephp/debug_kit Packagist | From 5.0.0 | 5.2.4 |
How do I fix CVE-2026-54614?
Upgrade cakephp/debug_kit to a fixed version for your release line: 4.10.3 or 5.2.4.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-54614 being exploited?
There is no known exploitation of CVE-2026-54614 in the wild and no public exploit code.
Sources
Also known as GHSA-p46m-g734-vpc4.