# CVE-2026-54617: GravitLauncher: Unauthenticated path traversal in LaunchServer FileServerHandler

> Unauthenticated attackers can read sensitive files via path traversal, exposing keys and credentials to enable authentication bypass.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** GHSA-5g75-477j-2c2f

## What is CVE-2026-54617?

CVE-2026-54617 is a critical path traversal vulnerability in GravitLauncher Launcher, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GravitLauncher is an open-source Minecraft launcher based on sashok724's v3. Prior to 5.7.12, an unauthenticated remote actor can send a raw HTTP request target without a leading slash to the default LaunchServer file server on port 9274. FileServerHandler.channelRead0 in components/launchserver/src/main/java/pro/gravit/launchserver/socket/handlers/fileserver/FileServerHandler.java strips the first request-target character and resolves the remaining path against updatesDir without re-normalizing and verifying containment. This leaves parent-directory components in a no-leading-slash request and allows reading any file accessible to the LaunchServer process, including .keys/ecdsa_id, .keys/legacySalt, and LaunchServer.json. Disclosure of those files can expose signing keys, refresh-token material, and database credentials, enabling forged administrative access tokens and full authentication bypass. A normalizing L7 proxy may block the primary request form, but direct exposure and L4/TCP proxies remain affected, and netty.fileServerEnabled is enabled by default. This issue is fixed in 5.7.12.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-54617?

2 open source packages ship an affected version, including pro.gravit.launcher:launchserver-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pro.gravit.launcher:launchserver-api` | Maven | All versions to 5.7.11 | None |
| `pro.gravit.launcher:launchserver-api` | Maven | All versions to 5.7.11 | None |

## How do I fix CVE-2026-54617?

No fix has been published for CVE-2026-54617 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54617 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54617 exists.

Public exploit code:

- GravitLauncher LaunchServer <=5.7.11 - Unauthenticated Path Traversal to Arbitrary File Read (nuclei): http/cves/2026/CVE-2026-54617.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54617 and fix it if it is affected.

What it is: CVE-2026-54617 is a critical path traversal vulnerability in GravitLauncher Launcher, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54617 exists.

Affected packages and fixed versions:
- pro.gravit.launcher:launchserver-api (Maven): affected all versions up to 5.7.11; no fix listed
- pro.gravit.launcher:launchserver-api (Maven): affected all versions up to 5.7.11; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54617/ (Markdown: https://insights.sbomify.com/CVE-2026-54617/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54617
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54617
- OSV: https://osv.dev/vulnerability/CVE-2026-54617

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54617/
Summaries are generated and may contain mistakes; the official description above is the record.
