# CVE-2026-54619: sqlite3-ruby has Use-After-Free When Redefining SQLite Functions with Different Arity

> Redefining SQLite functions with different arity in sqlite3-ruby causes a use-after-free, potentially allowing code execution or crashes.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-54619, GHSA-28hh-pr2h-2w89, UBUNTU-CVE-2026-54619

## What is CVE-2026-54619?

CVE-2026-54619 is a low-severity use after free vulnerability in sparklemotion sqlite3-ruby, published on 28 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

sqlite3 provides Ruby bindings for the SQLite3 embedded database. In version 2.9.4 and earlier, redefining a SQLite function with a different arity frees the previously registered function handler while SQLite may still reference it, resulting in a use-after-free. This issue is fixed in version 2.9.5.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2026-54619?

4 open source packages ship an affected version, including sqlite3-ruby and sqlite3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sqlite3-ruby` | RubyGems | All versions | 2.9.5 |
| `sqlite3-ruby` | RubyGems | All versions | 2.9.5 |
| `sqlite3` | RubyGems | All versions | 2.9.5 |
| `sqlite3` | RubyGems | All versions | 2.9.5 |

## How do I fix CVE-2026-54619?

Upgrade sqlite3-ruby to 2.9.5 or later.

## Is CVE-2026-54619 being exploited?

There is no known exploitation of CVE-2026-54619 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54619 and fix it if it is affected.

What it is: CVE-2026-54619 is a low-severity use after free vulnerability in sparklemotion sqlite3-ruby, published on 28 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54619 in the wild and no public exploit code.

Affected packages and fixed versions:
- sqlite3-ruby (RubyGems): affected all versions; fixed in 2.9.5
- sqlite3-ruby (RubyGems): affected all versions; fixed in 2.9.5
- sqlite3 (RubyGems): affected all versions; fixed in 2.9.5
- sqlite3 (RubyGems): affected all versions; fixed in 2.9.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54619/ (Markdown: https://insights.sbomify.com/CVE-2026-54619/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54619
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54619
- OSV: https://osv.dev/vulnerability/CVE-2026-54619

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54619/
Summaries are generated and may contain mistakes; the official description above is the record.
