# CVE-2026-54623: django CMS: Plugin move endpoint allows cyclic reparenting (DoS)

> A staff user can create cyclic plugin relationships in django CMS, causing infinite recursion and denial of service during rendering or tree operations.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2026
- **Updated:** 20 Aug 2026
- **Also known as:** GHSA-8jj7-4v57-frf5, PYSEC-2026-3822

## What is CVE-2026-54623?

CVE-2026-54623 is a high-severity denial of service vulnerability in django-cms, published on 20 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

django CMS is an easy-to-use and developer-friendly enterprise content management system powered by Django. Prior to 5.0.8, the move_plugin endpoint in cms/admin/placeholderadmin.py accepts an attacker-controlled plugin_parent value without rejecting a plugin’s own identifier or a descendant identifier. A staff user with plugin-change permission under CMS_PERMISSION can create a parent_id cycle in the plugin tree. The _get_descendants_cte and _get_ancestors_cte queries in cms/models/pluginmodel.py have no cycle guard, so get_descendants() and later rendering, copy, or delete operations can recurse indefinitely or reach a database recursion limit, corrupting the tree and consuming request workers. This issue is fixed in versions 5.0.8.

Weakness: CWE-835 (Loop with Unreachable Exit Condition), CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-54623?

3 open source packages ship an affected version, including django-cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django-cms` | PyPI | All versions | 5.0.8 |
| `django-cms` | PyPI | All versions | 5.0.8 |
| `django-cms` | PyPI | All versions | 5.0.8 |

## How do I fix CVE-2026-54623?

Upgrade django-cms to 5.0.8 or later.

## Is CVE-2026-54623 being exploited?

There is no known exploitation of CVE-2026-54623 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54623 and fix it if it is affected.

What it is: CVE-2026-54623 is a high-severity denial of service vulnerability in django-cms, published on 20 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54623 in the wild and no public exploit code.

Affected packages and fixed versions:
- django-cms (PyPI): affected all versions; fixed in 5.0.8
- django-cms (PyPI): affected all versions; fixed in 5.0.8
- django-cms (PyPI): affected all versions; fixed in 5.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54623/ (Markdown: https://insights.sbomify.com/CVE-2026-54623/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54623
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54623
- OSV: https://osv.dev/vulnerability/CVE-2026-54623

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54623/
Summaries are generated and may contain mistakes; the official description above is the record.
