# CVE-2026-54628: Anyquery: Server-Side Request Forgery (SSRF) via Unrestricted SQLite Virtual Table Modules in Server Mode

> Remote attackers can exploit unrestricted SQLite virtual table modules in Anyquery server to perform Server-Side Request Forgery, accessing internal networks and cloud metadata.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-hwrq-8wxh-q4xv, GO-2026-5988

## What is CVE-2026-54628?

CVE-2026-54628 is a high-severity server-side request forgery vulnerability in julien040 anyquery, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Anyquery is an SQL query engine built on top of SQLite. Prior to 0.4.5, anyquery server exposes URL-capable SQLite virtual table modules such as json_reader and log_reader through its unauthenticated MySQL-compatible server port without restricting outbound destinations. A remote attacker can provide a loopback, private-network, or link-local cloud metadata URL, causing go-getter in the Anyquery server process to fetch the selected resource and expose its response as queryable table data. This permits internal network probing, access to internal APIs, and disclosure of cloud credentials; low-integrity impact is possible when a reached internal API performs state-changing actions. This issue is fixed in version 0.4.5.

Weakness: CWE-862 (Missing Authorization), CWE-918 (Server-Side Request Forgery), CWE-441 (Unintended Proxy or Intermediary), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-54628?

3 open source packages ship an affected version, including github.com/julien040/anyquery.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/julien040/anyquery` | Go | All versions | None |
| `github.com/julien040/anyquery` | Go | All versions | None |
| `github.com/julien040/anyquery` | Go | All versions | None |

## How do I fix CVE-2026-54628?

Upgrade to a fixed version.

## Is CVE-2026-54628 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54628 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54628 and fix it if it is affected.

What it is: CVE-2026-54628 is a high-severity server-side request forgery vulnerability in julien040 anyquery, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54628 exists.

Affected packages and fixed versions:
- github.com/julien040/anyquery (Go): affected all versions; no fix listed
- github.com/julien040/anyquery (Go): affected all versions; no fix listed
- github.com/julien040/anyquery (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54628/ (Markdown: https://insights.sbomify.com/CVE-2026-54628/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54628
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54628
- OSV: https://osv.dev/vulnerability/CVE-2026-54628

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54628/
Summaries are generated and may contain mistakes; the official description above is the record.
