# CVE-2026-54631: Part-DB: Hardcoded APP_SECRET enables forged remember-me cookie


- **Severity:** Medium 6.3 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-99pw-2v29-v4wc

## What is CVE-2026-54631?

CVE-2026-54631 is a medium-severity vulnerability in Part-DB-server, published on 23 Oct 2026. 

### Official description

Part-DB is an open source inventory management system for electronic components. Prior to version 2.12.1, the file .env committed in the Part-DB repository contains a fixed value for APP_SECRET (a03498528f5a5fc089273ec9ae5b2849). The official Docker image jbtronics/part-db1 does not override or randomize this value at container start-up. Because Symfony uses APP_SECRET (via kernel.secret) as the HMAC key for signing remember-me cookies, any attacker who knows the secret -- or fetches it from the public repository -- can forge an arbitrary-user remember-me cookie and gain a fully authenticated session with no credentials required. This issue has been patched in version 2.12.1.

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2026-54631?


## How do I fix CVE-2026-54631?

No fix has been published for CVE-2026-54631 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54631 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54631 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54631 and fix it if it is affected.

What it is: CVE-2026-54631 is a medium-severity vulnerability in Part-DB-server, published on 23 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54631 exists.

Affected product: Part-DB-server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54631/ (Markdown: https://insights.sbomify.com/CVE-2026-54631/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54631
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54631
- OSV: https://osv.dev/vulnerability/CVE-2026-54631

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54631/
Summaries are generated and may contain mistakes; the official description above is the record.
