# CVE-2026-54632: SIPSorcery: Malformed UDP packet on the RTP/ICE socket can remotely terminate a media session (DoS)

> Remote attackers can terminate active media sessions by sending malformed UDP packets to the RTP/ICE socket in the SIPSorcery library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-28gm-jrmw-xx93

## What is CVE-2026-54632?

CVE-2026-54632 is a high-severity denial of service vulnerability in sipsorcery-org sipsorcery, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SIPSorcery is a WebRTC, SIP, and VoIP library for C# and .NET. Prior to 10.0.9, RTPChannel.OnRTPPacketReceived and the STUNAttribute.ParseMessageAttributes, STUNXORAddressAttribute, and STUNAddressAttribute parsing path index untrusted bytes without sufficient length checks, while UdpReceiver.EndReceiveFrom closes the channel when those operations raise a non-socket exception. A remote party can send a single short RTP packet or malformed zero-to-seven-byte STUN address attribute to the shared RTP/ICE socket, including during ICE connectivity checks before DTLS or STUN MESSAGE-INTEGRITY verification, and terminate the active RTP or WebRTC media session. The attacker must reach or learn the advertised ephemeral RTP/ICE port, but no authentication or user interaction is required, and the impact is limited to availability. This issue is fixed in version 10.0.9.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-54632?

2 open source packages ship an affected version, including SIPSorcery.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `SIPSorcery` | NuGet | All versions | 10.0.9 |
| `SIPSorcery` | NuGet | All versions | 10.0.9 |

## How do I fix CVE-2026-54632?

Upgrade SIPSorcery to 10.0.9 or later.

## Is CVE-2026-54632 being exploited?

There is no known exploitation of CVE-2026-54632 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54632 and fix it if it is affected.

What it is: CVE-2026-54632 is a high-severity denial of service vulnerability in sipsorcery-org sipsorcery, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54632 in the wild and no public exploit code.

Affected packages and fixed versions:
- SIPSorcery (NuGet): affected all versions; fixed in 10.0.9
- SIPSorcery (NuGet): affected all versions; fixed in 10.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54632/ (Markdown: https://insights.sbomify.com/CVE-2026-54632/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54632
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54632
- OSV: https://osv.dev/vulnerability/CVE-2026-54632

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54632/
Summaries are generated and may contain mistakes; the official description above is the record.
