# CVE-2026-54641: OpenRemote: Cross-Realm User Information Disclosure in UserResourceImpl

> A realm administrator can access user profiles and roles from other tenants or the master realm, breaking tenant isolation and exposing privileged account information.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-xqr9-4wvv-gvch

## What is CVE-2026-54641?

CVE-2026-54641 is a high-severity vulnerability in openremote, published on 13 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenRemote is an open-source internet-of-things platform. Prior to 1.24.2, the get, getUserClientRoles, and getUserRealmRoles methods in manager/src/main/java/org/openremote/manager/security/UserResourceImpl.java authorize callers with the read:admin role without confirming that the target UUID belongs to the requested and authenticated realm. A realm administrator can supply a user identifier from another tenant or the master realm and retrieve that user's profile, client roles, and realm roles, breaking tenant isolation and exposing privileged account information. This issue is fixed in version 1.24.2.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-54641?

2 open source packages ship an affected version, including io.openremote:openremote-manager.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.openremote:openremote-manager` | Maven | All versions | 1.24.2 |
| `io.openremote:openremote-manager` | Maven | All versions | 1.24.2 |

## How do I fix CVE-2026-54641?

Upgrade io.openremote:openremote-manager to 1.24.2 or later.

## Is CVE-2026-54641 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54641 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54641 and fix it if it is affected.

What it is: CVE-2026-54641 is a high-severity vulnerability in openremote, published on 13 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54641 exists.

Affected packages and fixed versions:
- io.openremote:openremote-manager (Maven): affected all versions; fixed in 1.24.2
- io.openremote:openremote-manager (Maven): affected all versions; fixed in 1.24.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54641/ (Markdown: https://insights.sbomify.com/CVE-2026-54641/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54641
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54641
- OSV: https://osv.dev/vulnerability/CVE-2026-54641

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54641/
Summaries are generated and may contain mistakes; the official description above is the record.
