# CVE-2026-54644: CubeCart: XSS via Anchor Tag Attribute Injection in gui.class.php Message System

> Attackers can inject JavaScript via anchor tags in error messages, leading to session hijacking or unauthorized actions in CubeCart.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 17 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** GHSA-v55x-fh73-29vq

## What is CVE-2026-54644?

CVE-2026-54644 is a medium-severity cross-site scripting vulnerability in cubecart v6, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CubeCart is an ecommerce software solution. Prior to 6.7.5, the _errorMessage method in classes/gui.class.php uses strip_tags to permit anchor elements in error, information, and warning messages while retaining unsafe href values and onclick event handlers. Attacker-controlled search or input data that reaches a GUI message can carry a javascript: URI or event handler through the filter, and viewing or interacting with the rendered anchor executes JavaScript in the victim's browser session, enabling session exposure or unauthorized application actions. This issue is fixed in version 6.7.5.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-54644?


## How do I fix CVE-2026-54644?

No fix has been published for CVE-2026-54644 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54644 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54644 exists.

Public exploit code:

- CubeCart 6.7.4 - Cross-Site Scripting (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54644 and fix it if it is affected.

What it is: CVE-2026-54644 is a medium-severity cross-site scripting vulnerability in cubecart v6, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54644 exists.

Affected product: cubecart v6. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54644/ (Markdown: https://insights.sbomify.com/CVE-2026-54644/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54644
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54644
- OSV: https://osv.dev/vulnerability/CVE-2026-54644

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54644/
Summaries are generated and may contain mistakes; the official description above is the record.
