# CVE-2026-54653: `datamodel-code-generator` vulnerable to code injection in via attacker-controlled `default_factory` schema field

> Attackers can execute arbitrary Python code by injecting malicious expressions into the default_factory field of generated models.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-386q-5hp3-95m9, MINI-qxgq-537q-pph4, PYSEC-2026-3555

## What is CVE-2026-54653?

CVE-2026-54653 is a high-severity code injection vulnerability in koxudaxi datamodel-code-generator, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

datamodel-code-generator generates Pydantic v2 models, dataclasses, TypedDict, and msgspec.Struct from OpenAPI, JSON Schema, GraphQL, Avro, Protobuf, and raw JSON, YAML, or CSV. From  0.17.0 until 0.60.2, datamodel-code-generator preserves attacker-controlled default_factory values in src/datamodel_code_generator/parser/jsonschema.py through JsonSchemaObject.init and get_field_extras and emits them into Field(default_factory=...) or field(default_factory=...), allowing Python expression execution when the generated model is imported. This issue is fixed in version 0.60.2.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-54653?

3 open source packages ship an affected version, including datamodel-code-generator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `datamodel-code-generator` | PyPI | From 0.17.0 | 0.60.2 |
| `datamodel-code-generator` | PyPI | From 0.17.0 | 0.60.2 |
| `datamodel-code-generator` | PyPI | From 0.17.0 | 0.60.2 |

Products: Koxudaxi Datamodel-Code-Generator.

## How do I fix CVE-2026-54653?

Upgrade datamodel-code-generator to 0.60.2 or later.

## Is CVE-2026-54653 being exploited?

There is no known exploitation of CVE-2026-54653 in the wild and no public exploit code.

## Other vulnerabilities in koxudaxi datamodel-code-generator

- [CVE-2026-54690](https://insights.sbomify.com/CVE-2026-54690/): datamodel-code-generator vulnerable to SSRF via JSON-Schema `$ref` to HTTP URL (silent by default) (high 8.2)
- [CVE-2026-54656](https://insights.sbomify.com/CVE-2026-54656/): `datamodel-code-generator` vulnerable to code execution on import via unescaped `validators` entries in --extra-template-data (high 7.8)
- [CVE-2026-55389](https://insights.sbomify.com/CVE-2026-55389/): datamodel-code-generator vulnerable to arbitrary local file read via JSON-Schema `$ref` (`file://` and `../` traversal), bypassing `--no-allow-remote-refs` (high 7.5)
- [CVE-2026-55391](https://insights.sbomify.com/CVE-2026-55391/): datamodel-code-generator vulnerable to SSRF protection bypass via DNS rebinding (high 7.5)
- [CVE-2026-55415](https://insights.sbomify.com/CVE-2026-55415/): datamodel-code-generator vulnerable to code injection via `x-python-import` / `customTypePath` in generated import statements (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54653 and fix it if it is affected.

What it is: CVE-2026-54653 is a high-severity code injection vulnerability in koxudaxi datamodel-code-generator, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-54653 in the wild and no public exploit code.

Affected packages and fixed versions:
- datamodel-code-generator (PyPI): affected from 0.17.0; fixed in 0.60.2
- datamodel-code-generator (PyPI): affected from 0.17.0; fixed in 0.60.2
- datamodel-code-generator (PyPI): affected from 0.17.0; fixed in 0.60.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54653/ (Markdown: https://insights.sbomify.com/CVE-2026-54653/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54653
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54653
- OSV: https://osv.dev/vulnerability/CVE-2026-54653

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54653/
Summaries are generated and may contain mistakes; the official description above is the record.
