# CVE-2026-54655: `datamodel-code-generator` vulnerable to code execution on import via `x-python-type` JSON-Schema extension in datamodel-code-generator

> Attacker-controlled JSON Schema content can execute Python code when generated modules are imported, affecting users of datamodel-code-generator.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-m34r-v34r-rf9q, PYSEC-2026-3562

## What is CVE-2026-54655?

CVE-2026-54655 is a high-severity code injection vulnerability in koxudaxi datamodel-code-generator, published on 28 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

datamodel-code-generator generates Python data models from schema definitions. From 0.51.0 until 0.60.2, x-python-type values parsed by src/datamodel_code_generator/parser/jsonschema.py in _get_python_type_override are inserted into generated field annotations without sufficient validation, allowing attacker-controlled JSON Schema content to execute Python code when the generated module is imported. This issue is fixed in version 0.60.2.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-54655?

3 open source packages ship an affected version, including datamodel-code-generator.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `datamodel-code-generator` | PyPI | From 0.51.0 | 0.60.2 |
| `datamodel-code-generator` | PyPI | From 0.51.0 | 0.60.2 |
| `datamodel-code-generator` | PyPI | From 0.51.0 | 0.60.2 |

## How do I fix CVE-2026-54655?

Upgrade datamodel-code-generator to 0.60.2 or later.

## Is CVE-2026-54655 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54655 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54655 and fix it if it is affected.

What it is: CVE-2026-54655 is a high-severity code injection vulnerability in koxudaxi datamodel-code-generator, published on 28 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54655 exists.

Affected packages and fixed versions:
- datamodel-code-generator (PyPI): affected from 0.51.0; fixed in 0.60.2
- datamodel-code-generator (PyPI): affected from 0.51.0; fixed in 0.60.2
- datamodel-code-generator (PyPI): affected from 0.51.0; fixed in 0.60.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54655/ (Markdown: https://insights.sbomify.com/CVE-2026-54655/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54655
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54655
- OSV: https://osv.dev/vulnerability/CVE-2026-54655

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54655/
Summaries are generated and may contain mistakes; the official description above is the record.
