{"answers":{"affected":"2 open source packages ship an affected version, including swagger-typescript-api.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54660 exists.","fix":"Upgrade swagger-typescript-api to 13.12.2 or later.","what":"CVE-2026-54660 is a high-severity server-side request forgery vulnerability in acacode swagger-typescript-api, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-54660 and fix it if it is affected.\n\nWhat it is: CVE-2026-54660 is a high-severity server-side request forgery vulnerability in acacode swagger-typescript-api, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54660 exists.\n\nAffected packages and fixed versions:\n- swagger-typescript-api (npm): affected all versions; fixed in 13.12.2\n- swagger-typescript-api (npm): affected all versions; fixed in 13.12.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54660/ (Markdown: https://insights.sbomify.com/CVE-2026-54660/index.md)","id":"CVE-2026-54660","markdown":"https://insights.sbomify.com/CVE-2026-54660/index.md","name":"CVE-2026-54660","record":{"aliases":["GHSA-h754-fxp7-88wx"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenAPI client generator","requires_auth":"none","summary":"Attackers can exfiltrate developer or CI bearer tokens by providing a malicious OpenAPI specification with external references.","user_interaction":"required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-522","name":"Insufficiently Protected Credentials"},{"id":"CWE-201","name":"Insertion of Sensitive Information Into Sent Data"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"swagger-typescript-api generates API clients for Fetch or Axios from OpenAPI specifications. Prior to 13.12.2, src/resolved-swagger-schema.ts getRemoteRequestHeaders forwards --authorizationToken to every URL fetched by fetchRemoteSchemaDocument while warmUpRemoteSchemasCache resolves external $ref URLs, allowing an attacker-controlled OpenAPI spec to exfiltrate the developer or CI bearer token to a cross-origin endpoint. This issue is fixed in version 13.12.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"swagger-typescript-api vulnerable to authorization-token exfiltration via spec `$ref`","id":"CVE-2026-54660","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"swagger-typescript-api vulnerable to code injection via unescaped `servers[0].url` in axios http-client template","id":"CVE-2026-54661"},"packages":[{"ecosystem":"npm","fixed":["13.12.2"],"introduced":["0"],"last_affected":[],"package":"swagger-typescript-api","purl":null,"source":"GHSA-h754-fxp7-88wx"},{"ecosystem":"npm","fixed":["13.12.2"],"introduced":["0"],"last_affected":[],"package":"swagger-typescript-api","purl":"pkg:npm/swagger-typescript-api","source":"GHSA-h754-fxp7-88wx"}],"prev":{"headline":"Pagy I18n locale option is not validated before being used in a file path","id":"CVE-2026-54659"},"products":["swagger-typescript-api"],"published":"2026-07-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-30","vendors":["acacode"]},"summary":"Attackers can exfiltrate developer or CI bearer tokens by providing a malicious OpenAPI specification with external references.","url":"https://insights.sbomify.com/CVE-2026-54660/"}