# CVE-2026-54663: swagger-typescript-api vulnerable to Server-Side Request Forgery via spec `$ref`

> An attacker can craft a malicious OpenAPI spec to force the generator to make requests to internal services, potentially exposing sensitive data.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-x36r-4347-pm5x

## What is CVE-2026-54663?

CVE-2026-54663 is a medium-severity server-side request forgery vulnerability in acacode swagger-typescript-api, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

swagger-typescript-api generates API clients for Fetch or Axios from OpenAPI specifications. Prior to 13.12.2, src/resolved-swagger-schema.ts warmUpRemoteSchemasCache resolves external $ref URLs and fetchRemoteSchemaDocument uses isHttpUrl to fetch any http or https target without private IP, redirect, DNS rebinding, or same-origin validation, allowing an attacker-controlled OpenAPI spec to make the generator issue requests to internal or link-local services. This issue is fixed in version 13.12.2.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-441 (Unintended Proxy or Intermediary), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-54663?

2 open source packages ship an affected version, including swagger-typescript-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `swagger-typescript-api` | npm | All versions | 13.12.2 |
| `swagger-typescript-api` | npm | All versions | 13.12.2 |

## How do I fix CVE-2026-54663?

Upgrade swagger-typescript-api to 13.12.2 or later.

## Is CVE-2026-54663 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54663 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54663 and fix it if it is affected.

What it is: CVE-2026-54663 is a medium-severity server-side request forgery vulnerability in acacode swagger-typescript-api, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54663 exists.

Affected packages and fixed versions:
- swagger-typescript-api (npm): affected all versions; fixed in 13.12.2
- swagger-typescript-api (npm): affected all versions; fixed in 13.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54663/ (Markdown: https://insights.sbomify.com/CVE-2026-54663/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54663
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54663
- OSV: https://osv.dev/vulnerability/CVE-2026-54663

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54663/
Summaries are generated and may contain mistakes; the official description above is the record.
