# CVE-2026-54665: Apache NiFi: Missing Validation for Proxy Host Headers

> Attackers can manipulate proxy headers to force Apache NiFi to generate malicious redirect URLs, bypassing host validation controls.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N/S:N/AU:Y/R:A/V:D/RE:L/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** BIT-nifi-2026-54665, CLEANSTART-2026-GJ69600, CLEANSTART-2026-SJ80754, GHSA-8vm2-c32j-mvfr, MINI-4pj2-vgp2-f9fc

## What is CVE-2026-54665?

CVE-2026-54665 is a medium-severity vulnerability in Apache Nifi, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache NiFi 0.0.1 through 2.9.0 support building qualified URLs from one of several HTTP request headers that provide an alternative to the standard Host header without validating the values provided. Apache NiFi 1.6.0 introduced a configurable application property to restrict values provided in the HTTP Host header, but did not apply the validation to alternative Proxy and Forwarded headers. The absence of proxy host header validation allowed a client to instruct Apache NiFi web services to construct invalid qualified URLs for redirection or data references. Upgrading to Apache NiFi 2.10.0 is the recommended mitigation, which implements validation for the X-ProxyHost and X-Forwarded-Host HTTP request headers based on the nifi.web.proxy.host property. Enabling header validation requires configuring the application with HTTPS. Reverse proxy servers in front of Apache NiFi are responsible for filtering input request headers and providing allowed values to the application.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-54665?

3 open source packages ship an affected version, including org.apache.nifi:nifi-jetty and nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi-jetty` | Maven | All versions | 2.10.0 |
| `org.apache.nifi:nifi-jetty` | Maven | All versions | 2.10.0 |
| `nifi` | Bitnami | From 0.0.1 | 2.10.0 |

Products: Apache Nifi.

## How do I fix CVE-2026-54665?

Upgrade org.apache.nifi:nifi-jetty to 2.10.0 or later.

## Is CVE-2026-54665 being exploited?

There is no known exploitation of CVE-2026-54665 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54665 and fix it if it is affected.

What it is: CVE-2026-54665 is a medium-severity vulnerability in Apache Nifi, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54665 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi:nifi-jetty (Maven): affected all versions; fixed in 2.10.0
- org.apache.nifi:nifi-jetty (Maven): affected all versions; fixed in 2.10.0
- nifi (Bitnami): affected from 0.0.1; fixed in 2.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54665/ (Markdown: https://insights.sbomify.com/CVE-2026-54665/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54665
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54665
- OSV: https://osv.dev/vulnerability/CVE-2026-54665

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54665/
Summaries are generated and may contain mistakes; the official description above is the record.
