# CVE-2026-54679: jq: potential integer overflow in jvp_string_append

> An integer overflow in jq on 32-bit systems can lead to buffer overruns, potentially allowing code execution or denial of service.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** ALPINE-CVE-2026-54679, BELL-CVE-2026-54679, CLSA-2026-1782983956, DEBIAN-CVE-2026-54679, ECHO-dfa5-57c7-ba16, GHSA-29gj-222p-j7vx, UBUNTU-CVE-2026-54679

## What is CVE-2026-54679?

CVE-2026-54679 is a medium-severity vulnerability in jqlang jq, published on 25 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

jq is a command-line JSON processor. Prior to 1.8.2, on 32bit system, jvp_string_append has a chance of integer/multiple overflowing and then causing a massive buffer overrun.  This vulnerability is fixed in 1.8.2.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-54679?

It affects 1 product.


Products: Jqlang Jq.

## How do I fix CVE-2026-54679?

Upgrade to a fixed version.

## Is CVE-2026-54679 being exploited?

There is no known exploitation of CVE-2026-54679 in the wild and no public exploit code.

## Other vulnerabilities in jqlang jq

- [CVE-2026-32316](https://insights.sbomify.com/CVE-2026-32316/): jq: Integer overflow in jvp_string_append() allows Heap-based Buffer Overflow (high 8.2)
- [CVE-2024-53427](https://insights.sbomify.com/CVE-2024-53427/): Memory corruption in jq (high 8.1)
- [CVE-2025-48060](https://insights.sbomify.com/CVE-2025-48060/): AddressSanitizer: stack-buffer-overflow in jq_fuzz_execute (jv_string_vfmt) (high 7.7)
- [CVE-2023-49355](https://insights.sbomify.com/CVE-2023-49355/): Memory corruption in n/a (high 7.5)
- [CVE-2026-49839](https://insights.sbomify.com/CVE-2026-49839/): jq --rawfile invalid-state reuse after String too long causes heap-buffer-overflow (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54679 and fix it if it is affected.

What it is: CVE-2026-54679 is a medium-severity vulnerability in jqlang jq, published on 25 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54679 in the wild and no public exploit code.

Affected product: jqlang jq. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54679/ (Markdown: https://insights.sbomify.com/CVE-2026-54679/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54679
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54679
- OSV: https://osv.dev/vulnerability/CVE-2026-54679

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54679/
Summaries are generated and may contain mistakes; the official description above is the record.
